Skip to content
Snippets Groups Projects
Commit 176b858e authored by Esben Haabendal's avatar Esben Haabendal
Browse files

prebuilts: Fix support for multiple --ninja-args arguments


Signed-off-by: default avatarEsben Haabendal <esben.haabendal@huawei.com>
parent 8503494b
No related branches found
No related tags found
1 merge request!38CI: Attempt to throttle load caused by builds better
......@@ -2,5 +2,4 @@
#
# SPDX-License-Identifier: Apache-2.0
# This file is intentionally left empty.
# It is needed so the 'require' statement in oniro-openharmony-toolchain-integration.bb doesn't fail
SRC_URI += "file://patches/build-ninja_args.patch;apply=no;subdir=src"
# SPDX-FileCopyrightText: Huawei Inc.
#
# SPDX-License-Identifier: Apache-2.0
Patch for //build git repository of OpenHarmony 3.0 codebase.
This fixes support for using --ninja-args argument multiple times with build.sh
script.
Signed-off-by: Esben Haabendal <esben.haabendal@huawei.com>
Upstream-Status: Pending
diff --git a/build/core/build_scripts/parse_cmdline.sh b/build/core/build_scripts/parse_cmdline.sh
index d8e351ede111..b7a49a2d04ca 100755
--- a/build/core/build_scripts/parse_cmdline.sh
+++ b/build/core/build_scripts/parse_cmdline.sh
@@ -33,7 +33,7 @@ parse_cmdline()
variant) BUILD_VARIANT="$PARAM" ;;
out_dir) OUT_DIR="$PARAM" ;;
gn_args) GN_ARGS="$GN_ARGS $PARAM" ;;
- ninja_args) NINJA_ARGS="$PARAM" ;;
+ ninja_args) NINJA_ARGS="$NINJA_ARGS $PARAM" ;;
versionmode) TARGET_VERSION_MODE="$PARAM" ;;
coverage) COVERAGE="$PARAM" ;;
custom_clang) CUSTOM_CLANG="$PARAM" ;;
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment