-
Kareem Zarka authored
for ActsAmsZipfileUnzipfileSTest This commit adds a new recipe that installs the missing ACTS test files. The files are then used by the OpenHarmony Standard recipe to place them in the correct location for the ActsAmsZipfileUnzipfileSTest to execute. Signed-off-by:
Kareem Zarka <kareem.zarka@huawei.com>
Kareem Zarka authoredfor ActsAmsZipfileUnzipfileSTest This commit adds a new recipe that installs the missing ACTS test files. The files are then used by the OpenHarmony Standard recipe to place them in the correct location for the ActsAmsZipfileUnzipfileSTest to execute. Signed-off-by:
Kareem Zarka <kareem.zarka@huawei.com>
Code owners
Assign users and groups as approvers for specific file changes. Learn more.
openharmony-acts-resources.bb 894 B
# SPDX-FileCopyrightText: Huawei Inc.
#
# SPDX-License-Identifier: MIT
SUMMARY = "ACTS Resources For OpenHarmony Test Suite"
DESCRIPTION = "This recipe installs the necessary resource files for running the OpenHarmony ACTS test suite."
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
DEPENDS += "zip-native"
SRC_URI = "file://ceshi.txt \
file://ceshitwo.txt"
S = "${WORKDIR}"
# install missing resources of ACTS tests
do_install() {
appexecfwk_dir="${D}${libexecdir}/openharmony-standard/acts/resource/appexecfwk/"
install -d ${appexecfwk_dir}
install -m 0644 ${WORKDIR}/ceshi.txt ${appexecfwk_dir}
install -m 0644 ${WORKDIR}/ceshitwo.txt ${appexecfwk_dir}
cd ${appexecfwk_dir}
# generate the zip file from ceshitwo.txt
zip ceshitwo.zip ceshitwo.txt
}
PACKAGES = "${PN}"
FILES:${PN} = "/"