-
Thierry Escande authored
This moves the 3.0 specific patches and files to an openharmony-3.0 directory. Instead of using DISTRO_VERSION, this now uses OHOS_VERSION to determine which OpenHarmony is built. DISTRO_VERSION has been reset to 1.99.99 to stick to oniro-core and avoid confusion with OpenHarmony version (3.0 or 3.1 for now). Signed-off-by:
Thierry Escande <thierry.escande@huawei.com>
Thierry Escande authoredThis moves the 3.0 specific patches and files to an openharmony-3.0 directory. Instead of using DISTRO_VERSION, this now uses OHOS_VERSION to determine which OpenHarmony is built. DISTRO_VERSION has been reset to 1.99.99 to stick to oniro-core and avoid confusion with OpenHarmony version (3.0 or 3.1 for now). Signed-off-by:
Thierry Escande <thierry.escande@huawei.com>
Code owners
Assign users and groups as approvers for specific file changes. Learn more.
oniro-openharmony-thirdparty-integration.bb 937 B
# SPDX-FileCopyrightText: Huawei Inc.
#
# SPDX-License-Identifier: Apache-2.0
SUMMARY = "Integration of Oniro 3rd party components into OpenHarmony"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://overlay/third_party/openssl/BUILD.gn;beginline=1;endline=3;md5=a1537856660cf2c8e36079c007b35bec"
BBCLASSEXTEND = "native nativesdk"
INHIBIT_DEFAULT_DEPS = "1"
DEPENDS += "oniro-openharmony-toolchain-integration"
S = "${WORKDIR}/src"
B = "${WORKDIR}/build"
FILESEXTRAPATHS:prepend := "${THISDIR}/openharmony-${OPENHARMONY_VERSION}:"
SRC_URI += "file://patches/build_third_party.patch;apply=no;subdir=src"
SRC_URI += "file://third_party/openssl/BUILD.gn;subdir=src/overlay"
require oniro-openharmony-thirdparty-integration-${OPENHARMONY_VERSION}.inc
do_install() {
mkdir -p ${D}${datadir}/oniro-openharmony
cp -rv ${S}/* ${D}${datadir}/oniro-openharmony/
}
PACKAGES = "${PN}"
FILES:${PN} = "${datadir}/oniro-openharmony"