Skip to content
Snippets Groups Projects
Commit 76609308 authored by Davide Gardenal's avatar Davide Gardenal
Browse files

Merge remote-tracking branch 'upstream/master' into merge_upstream

parents e7793889 6544a70f
No related branches found
No related tags found
1 merge request!5Merge upstream/master
Pipeline #3247 passed with warnings
......@@ -8,7 +8,7 @@ inherit ${ZEPHYR_INHERIT_CLASSES}
require recipes-kernel/zephyr-kernel/zephyr-sample.inc
SRC_URI:append = "file://0001-zephyr-Export-an-OpenEmbedded-machine-config.patch"
SRC_URI:append = " file://0001-zephyr-Export-an-OpenEmbedded-machine-config.patch"
ZEPHYR_SRC_DIR = "${S}/samples/hello_world"
......
From 783c1f78c8e39751fe89d0883c8bce7336f55e94 Mon Sep 17 00:00:00 2001
From: Torsten Rasmussen <Torsten.Rasmussen@nordicsemi.no>
Date: Thu, 19 Aug 2021 08:53:00 +0200
Subject: [PATCH] cmake: added missing file ext to
lv_font_dejavu_16_persian_hebrew.c
CMake >= 3.20 requires file extensions explicitly added to source files.
See CMP0115:
> Starting in CMake 3.20, CMake prefers all source files to have their
> extensions explicitly listed:
In the CMakeLists.txt, the file lv_font_dejavu_16_persian_hebrew.c
was added without its .c extension, causing never CMakes ti fail
discovering the file.
This has been fixed by correctly add the file as:
lv_font_dejavu_16_persian_hebrew.c
Signed-off-by: Torsten Rasmussen <Torsten.Rasmussen@nordicsemi.no>
---
Upstream-status: Accepted
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 57b07c84..0f433edc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,7 +58,7 @@ zephyr_library_sources(
src/lv_misc/lv_utils.c
src/lv_font/lv_font.c
- src/lv_font/lv_font_dejavu_16_persian_hebrew
+ src/lv_font/lv_font_dejavu_16_persian_hebrew.c
src/lv_font/lv_font_fmt_txt.c
src/lv_font/lv_font_loader.c
src/lv_font/lv_font_montserrat_12.c
--
Gitee
commit 6c9945aafa00c09149e2052a9c2bccad16dd1d8a
Author: Stefan Schmidt <stefan.schmidt@huawei.com>
Date: Fri May 7 11:47:44 2021 +0200
boards/arduino_nano_33_ble: add storage partition at end of flash
Change default partition table to allow for application which need
storage. One use case is running the OpenThread integration which has
a dependency on this.
Upstream-Status: Backported [https://github.com/zephyrproject-rtos/zephyr/commit/6c9945aafa00c09149e2052a9c2bccad16dd1d8a]
Signed-off-by: Stefan Schmidt <stefan.schmidt@huawei.com>
Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
diff --git a/boards/arm/arduino_nano_33_ble/arduino_nano_33_ble.dts b/boards/arm/arduino_nano_33_ble/arduino_nano_33_ble.dts
index d09b66ec43..d11d800eb5 100644
--- a/boards/arm/arduino_nano_33_ble/arduino_nano_33_ble.dts
+++ b/boards/arm/arduino_nano_33_ble/arduino_nano_33_ble.dts
@@ -44,15 +44,27 @@
boot_partition: partition@0 {
label = "sam-ba";
- reg = <0x0 0x10000>;
+ reg = <0x00000000 0x00010000>;
read-only;
};
code_partition: partition@10000 {
label = "code";
- reg = <0x10000 0xf0000>;
+ reg = <0x00010000 0x000e8000>;
read-only;
};
+
+ /*
+ * The flash starting at 0x000f8000 and ending at
+ * 0x000fffff is reserved for use by the application.
+ *
+ * Storage partition will be used by FCB/LittleFS/NVS
+ * if enabled.
+ */
+ storage_partition: partition@f8000 {
+ label = "storage";
+ reg = <0x000f8000 0x00008000>;
+ };
};
};
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment