Verified Commit e08e5e87 authored by Andrei Gherzan's avatar Andrei Gherzan 🐧
Browse files

docs: Fix sphinx-tabs version in docs-builder

There is an incompatibility issue between the sphinx version in Ubuntu
focal and the docutils version pulled in by sphinx-tabs. We need to make
sure that pip doesn't pull in a version of docutils that would break
sphinx:

https://github.com/sphinx-doc/sphinx/issues/9841

Signed-off-by: Andrei Gherzan's avatarAndrei Gherzan <andrei.gherzan@huawei.com>
parent e890fe2d
......@@ -16,4 +16,7 @@ RUN apt-get update -qq \
&& eatmydata apt-get install -qq -y 'ca-certificates=20211016~20.04.1' \
&& eatmydata apt-get clean && rm -rf /var/lib/apt/lists/*
RUN pip3 install sphinx-tabs
# We need to fix the version here to avoid pulling docutils 0.18 which is
# incompatible with the sphinx version from Ubuntu focal. See more here:
# https://github.com/sphinx-doc/sphinx/issues/9841
RUN pip3 install sphinx-tabs==3.4.0
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment