From bafc7873c33bb9e36a8fda2f99d1bd4e868f115d Mon Sep 17 00:00:00 2001
From: Francesco Pham <francesco.pham@huawei.com>
Date: Thu, 11 May 2023 15:01:05 +0200
Subject: [PATCH] openharmony-standard: remove wlan_device_driver,
 wpa_supplicant,wifi_hal

remove wlan_device_driver, third-party-wpa-supplicant, wifi_hal
to arrange for network manager integration.

Signed-off-by: Francesco Pham <francesco.pham@huawei.com>
---
 .../openharmony/files/wifi_hal.service        | 15 -------
 .../files/wifi_hal.service.license            |  3 --
 .../openharmony-standard-sources-3.0.inc      |  3 --
 .../openharmony/openharmony-standard_3.0.bb   | 39 +------------------
 4 files changed, 2 insertions(+), 58 deletions(-)
 delete mode 100644 recipes-openharmony/openharmony/files/wifi_hal.service
 delete mode 100644 recipes-openharmony/openharmony/files/wifi_hal.service.license

diff --git a/recipes-openharmony/openharmony/files/wifi_hal.service b/recipes-openharmony/openharmony/files/wifi_hal.service
deleted file mode 100644
index c6b51781..00000000
--- a/recipes-openharmony/openharmony/files/wifi_hal.service
+++ /dev/null
@@ -1,15 +0,0 @@
-[Unit]
-Description=OpenHarmony Wi-Fi HAL service
-
-[Service]
-Type=exec
-User=root
-Group=root
-SupplementaryGroups=shell
-ExecStart=/usr/bin/wifi_hal_service
-Restart=on-failure
-StartLimitInterval=300
-StartLimitBurst=5
-
-[Install]
-WantedBy=multi-user.target
diff --git a/recipes-openharmony/openharmony/files/wifi_hal.service.license b/recipes-openharmony/openharmony/files/wifi_hal.service.license
deleted file mode 100644
index 98a0b3f4..00000000
--- a/recipes-openharmony/openharmony/files/wifi_hal.service.license
+++ /dev/null
@@ -1,3 +0,0 @@
-# SPDX-FileCopyrightText: Huawei Inc.
-#
-# SPDX-License-Identifier: Apache-2.0
diff --git a/recipes-openharmony/openharmony/openharmony-standard-sources-3.0.inc b/recipes-openharmony/openharmony/openharmony-standard-sources-3.0.inc
index 31dcbaa2..2bdeb597 100644
--- a/recipes-openharmony/openharmony/openharmony-standard-sources-3.0.inc
+++ b/recipes-openharmony/openharmony/openharmony-standard-sources-3.0.inc
@@ -415,9 +415,6 @@ SRCREV_FORMAT .= "+third_party_wayland_standard"
 SRC_URI += "${GITEE_URL}/third_party_weston.git;protocol=https;nobranch=1;branch=OpenHarmony-v3.0.1-LTS;name=third_party_weston;destsuffix=${OH_SRCDIR}/third_party/weston"
 SRCREV_third_party_weston = "a66a6bea4b93eca1077a8a2156b58084a8328b4d"
 SRCREV_FORMAT .= "+third_party_weston"
-SRC_URI += "${GITEE_URL}/third_party_wpa_supplicant.git;protocol=https;nobranch=1;branch=OpenHarmony-v3.0.1-LTS;name=third_party_wpa_supplicant;destsuffix=${OH_SRCDIR}/third_party/wpa_supplicant"
-SRCREV_third_party_wpa_supplicant = "45069e0558911a5bebf1bb3136efd58a48b041ed"
-SRCREV_FORMAT .= "+third_party_wpa_supplicant"
 SRC_URI += "${GITEE_URL}/third_party_xkeyboardconfig.git;protocol=https;nobranch=1;branch=OpenHarmony-v3.0.1-LTS;name=third_party_xkeyboardconfig;destsuffix=${OH_SRCDIR}/third_party/XKeyboardConfig"
 SRCREV_third_party_xkeyboardconfig = "0a9a2de029183789a6d87f7add90d2e81f594adc"
 SRCREV_FORMAT .= "+third_party_xkeyboardconfig"
diff --git a/recipes-openharmony/openharmony/openharmony-standard_3.0.bb b/recipes-openharmony/openharmony/openharmony-standard_3.0.bb
index be98b812..41e8b4f4 100644
--- a/recipes-openharmony/openharmony/openharmony-standard_3.0.bb
+++ b/recipes-openharmony/openharmony/openharmony-standard_3.0.bb
@@ -380,7 +380,6 @@ OPENHARMONY_PARTS += "global:resmgr_standard"
 OPENHARMONY_PARTS += "graphic:graphic_standard"
 OPENHARMONY_PARTS += "hdf:hdf"
 OPENHARMONY_PARTS += "hdf:display_device_driver"
-OPENHARMONY_PARTS += "hdf:wlan_device_driver"
 OPENHARMONY_PARTS += "hiviewdfx:faultloggerd"
 OPENHARMONY_PARTS += "hiviewdfx:hilog"
 OPENHARMONY_PARTS += "hiviewdfx:hilog_native"
@@ -414,7 +413,6 @@ OPENHARMONY_PARTS += "startup:startup_l2"
 OPENHARMONY_PARTS += "telephony:core_service"
 OPENHARMONY_PARTS += "telephony:ril_adapter"
 OPENHARMONY_PARTS += "utils:utils_base"
-OPENHARMONY_PARTS += "wpa_supplicant-2.9:wpa_supplicant-2.9"
 
 OPENHARMONY_PARTS += "${@bb.utils.contains('DISTRO_FEATURES', 'acts', 'xts:phone_tests', '', d)}"
 export XTS_SUITENAME = "${@bb.utils.contains('DISTRO_FEATURES', 'acts', 'acts', '', d)}"
@@ -819,14 +817,12 @@ RDEPENDS:${PN}-ptest += "${PN}-dsoftbus-ptest"
 # //foundation/communication/wifi
 PACKAGES =+ "${PN}-wifi"
 SYSTEMD_PACKAGES += "${PN}-wifi"
-SYSTEMD_SERVICE:${PN}-wifi = "wifi_standard.service wifi_hal.service"
-SRC_URI += "file://wifi_standard.service file://wifi_hal.service"
+SYSTEMD_SERVICE:${PN}-wifi = "wifi_standard.service"
+SRC_URI += "file://wifi_standard.service"
 do_install:append() {
     install -d ${D}/${systemd_unitdir}/system
     install -m 644 ${WORKDIR}/wifi_standard.service ${D}${systemd_unitdir}/system/
-    install -m 644 ${WORKDIR}/wifi_hal.service ${D}${systemd_unitdir}/system/
     rm -f ${D}${sysconfdir}/openharmony/init/wifi_standard.cfg
-    rm -f ${D}${sysconfdir}/openharmony/init/wifi_hal_service.cfg
 }
 FILES:${PN}-wifi = " \
     ${libdir}/libwifi*${SOLIBS} \
@@ -834,12 +830,10 @@ FILES:${PN}-wifi = " \
     ${bindir}/dhcp_server \
     ${bindir}/dhcp_client_service \
     ${libdir}/openharmony/profile/wifi_manager_service.xml \
-    ${bindir}/wifi_hal_service \
 "
 RDEPENDS:${PN} += "${PN}-wifi"
 RDEPENDS:${PN}-wifi += "musl libcxx"
 RDEPENDS:${PN}-wifi += "${PN}-samgr ${PN}-hilog ${PN}-libutils ${PN}-ipc ${PN}-safwk ${PN}-aafwk ${PN}-notification-ces ${PN}-appexecfwk"
-RDEPENDS:${PN}-wifi += "${PN}-thirdparty-wpa-supplicant"
 
 # //foundation/communication/wifi_native_js
 PACKAGES =+ "${PN}-wifi-native-js"
@@ -1227,24 +1221,6 @@ RDEPENDS:${PN}-peripheral-input += "musl libcxx"
 RDEPENDS:${PN}-peripheral-input += "${PN}-hilog ${PN}-libutils ${PN}-uhdf2"
 RDEPENDS:${PN} += "${PN}-peripheral-input"
 
-# //drivers/peripheral/wlan
-PACKAGES =+ "${PN}-peripheral-wlan"
-do_install:append() {
-    install -m 644 ${B}/hdf/hdf/libwifi_driver_client.z.so ${D}${libdir}/
-    install -m 644 ${B}/hdf/hdf/libwifi_hal.z.so ${D}${libdir}/
-    install -m 644 ${B}/hdf/hdf/libwifi_hdi_c_device.z.so ${D}${libdir}/
-    install -m 644 ${B}/hdf/hdf/libwifi_hdi_device.z.so ${D}${libdir}/
-}
-FILES:${PN}-peripheral-wlan = " \
-    ${libdir}/libwifi_driver_client*${SOLIBS} \
-    ${libdir}/libwifi_hal*${SOLIBS} \
-    ${libdir}/libwifi_hdi_c_device*${SOLIBS} \
-    ${libdir}/libwifi_hdi_device*${SOLIBS} \
-"
-RDEPENDS:${PN}-peripheral-wlan += "musl libcxx"
-RDEPENDS:${PN}-peripheral-wlan += "${PN}-hilog ${PN}-libutils ${PN}-uhdf2 ${PN}-ipc"
-RDEPENDS:${PN} += "${PN}-peripheral-wlan"
-
 # //base/miscservices/time
 PACKAGES =+ "${PN}-timeservice"
 SYSTEMD_PACKAGES += "${PN}-timeservice"
@@ -2100,17 +2076,6 @@ RDEPENDS:${PN}-thirdparty-weston += "${PN}-hilog ${PN}-libutils ${PN}-thirdparty
 RDEPENDS:${PN}-thirdparty-weston += "${PN}-thirdparty-libinput ${PN}-thirdparty-libevdev ${PN}-thirdparty-eudev ${PN}-thirdparty-pixman ${PN}-display-gralloc"
 RDEPENDS:${PN} += "${PN}-thirdparty-weston"
 
-PACKAGES =+ "${PN}-thirdparty-wpa-supplicant"
-FILES:${PN}-thirdparty-wpa-supplicant = " \
-    ${bindir}/hostapd \
-    ${bindir}/wpa_cli \
-    ${bindir}/wpa_supplicant \
-    ${libdir}/libwpa*${SOLIBS} \
-"
-RDEPENDS:${PN}-thirdparty-wpa-supplicant += "musl libcxx"
-RDEPENDS:${PN}-thirdparty-wpa-supplicant += "${PN}-peripheral-wlan"
-RDEPENDS:${PN} += "${PN}-thirdparty-wpa-supplicant"
-
 # Disable all ptest suites that are know to not work for now. When the x-bit is
 # not set, the ptest is visible (using `ptest-runner -l`), but no test cases
 # will be run when executing it.
-- 
GitLab