Commit 91898d96 authored by Yi Liu's avatar Yi Liu Committed by Christopher Guindon
Browse files

Update Hugo to 0.76.5 and theme to 0.0.102


Signed-off-by: Yi Liu's avatarYi Liu <yi.liu@eclipse-foundation.org>
parent 356bd014
......@@ -7,7 +7,7 @@ matrix:
env: HUGO_ENV=production
install:
- npm install
- wget https://github.com/gohugoio/hugo/releases/download/v0.62.2/hugo_0.62.2_Linux-64bit.deb
- wget https://github.com/gohugoio/hugo/releases/download/v0.76.5/hugo_0.76.5_Linux-64bit.deb
- sudo dpkg -i hugo*.deb
script:
- if [ "$HUGO_ENV" = "dev" ]; then hugo --gc --minify --buildFuture; fi;
......
......@@ -2,7 +2,7 @@ ARG NGINX_IMAGE_TAG=stable-alpine-for-hugo
FROM debian:10-slim AS builder
ARG HUGO_VERSION=0.62.2
ARG HUGO_VERSION=0.76.5
ARG NODE_VERSION=10.15.0
RUN apt-get update && apt-get install -y \
......
......@@ -28,7 +28,7 @@ pipeline {
}
parameters {
string(name: 'hugo_version', defaultValue: '0.62.2', description: 'The Hugo version that will be used to build the website. Must match versions speficied on https://github.com/gohugoio/hugo/releases.')
string(name: 'hugo_version', defaultValue: '0.76.5', description: 'The Hugo version that will be used to build the website. Must match versions speficied on https://github.com/gohugoio/hugo/releases.')
string(name: 'node_version', defaultValue: '10.15.3', description: 'The Node.js version that will be used to build the website. Must match versions specified on https://nodejs.org/en/download/releases/. It is adivsed to stick to LTS versions.')
}
......
......@@ -3,7 +3,7 @@ publish = "public"
command = "npm run build_netlify && hugo --gc --minify -b https://eclipsefdn-openmdm.netlify.com"
[context.production.environment]
HUGO_VERSION = "0.62.2"
HUGO_VERSION = "0.76.5"
HUGO_ENV = "production"
HUGO_ENABLEGITINFO = "true"
......@@ -11,20 +11,20 @@ HUGO_ENABLEGITINFO = "true"
command = "npm run build_netlify && hugo --gc --minify --enableGitInfo"
[context.split1.environment]
HUGO_VERSION = "0.62.2"
HUGO_VERSION = "0.76.5"
HUGO_ENV = "production"
[context.deploy-preview]
command = "npm run build_netlify && hugo --gc --minify --buildFuture -b $DEPLOY_PRIME_URL"
[context.deploy-preview.environment]
HUGO_VERSION = "0.62.2"
HUGO_VERSION = "0.76.5"
[context.branch-deploy]
command = "npm run build_netlify && hugo --gc --minify -b $DEPLOY_PRIME_URL"
[context.branch-deploy.environment]
HUGO_VERSION = "0.62.2"
HUGO_VERSION = "0.76.5"
[context.next.environment]
HUGO_ENABLEGITINFO = "true"
......@@ -22,6 +22,6 @@
"build_netlify": "NODE_ENV=production npm run disallow_robots_txt && npm run production"
},
"dependencies": {
"eclipsefdn-hugo-solstice-theme": "0.0.98"
"eclipsefdn-hugo-solstice-theme": "0.0.102"
}
}
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment