diff --git a/conf/distro/include/musl-ldso-paths.inc b/conf/distro/include/musl-ldso-paths.inc
index a76324bf2a5d14dd7b0514eecb2a28fd2d231612..6a69bc70566edbbff816a4edd4375b77d38fd379 100644
--- a/conf/distro/include/musl-ldso-paths.inc
+++ b/conf/distro/include/musl-ldso-paths.inc
@@ -20,4 +20,5 @@ MUSL_LDSO_PATHS:append:openharmony-3.1 = " \
 	module/multimodalinput \
 	module/net \
 	module/security \
+	module/useriam \
 "
diff --git a/recipes-core/fts/fts_%.bbappend b/recipes-core/fts/fts_%.bbappend
new file mode 100644
index 0000000000000000000000000000000000000000..2b66eb08c6064fc7bf39fa972a4afdc2819716c2
--- /dev/null
+++ b/recipes-core/fts/fts_%.bbappend
@@ -0,0 +1,5 @@
+# SPDX-FileCopyrightText: Huawei Inc.
+#
+# SPDX-License-Identifier: Apache-2.0
+
+FILES:${PN} += "${libdir}/*.a"
diff --git a/recipes-openharmony/openharmony/openharmony-standard-3.1/base_security_selinux-fts.patch b/recipes-openharmony/openharmony/openharmony-standard-3.1/base_security_selinux-fts.patch
new file mode 100644
index 0000000000000000000000000000000000000000..e3a276f85a0715eb2d9515e42eac24a5b86c6e72
--- /dev/null
+++ b/recipes-openharmony/openharmony/openharmony-standard-3.1/base_security_selinux-fts.patch
@@ -0,0 +1,38 @@
+# SPDX-FileCopyrightText: Huawei Inc.
+#
+# SPDX-License-Identifier: Apache-2.0
+
+Apply to //base/security/selinux of OpenHarmony 3.1 codebase.
+
+This makes use of the fts.h header file from //third_party/selinux instead
+of //third_party/FreeBSD that we avoid to use.
+
+Signed-off-by: Thierry Escande <thierry.escande@huawei.com>
+Upstream-Status: Inappropriate
+
+diff --git a/BUILD.gn b/BUILD.gn
+index 2badcfc..95f74fb 100644
+--- a/BUILD.gn
++++ b/BUILD.gn
+@@ -97,6 +97,7 @@ ohos_shared_library("libhap_restorecon") {
+     "-D_GNU_SOURCE",
+     "-Wall",
+     "-Werror",
++    "-Wno-error=#warnings",
+   ]
+   install_enable = true
+   license_file = "$SELINUX_ROOT_DIR/LICENSE"
+diff --git a/interfaces/policycoreutils/src/hap_restorecon.cpp b/interfaces/policycoreutils/src/hap_restorecon.cpp
+index eca095a..8333562 100644
+--- a/interfaces/policycoreutils/src/hap_restorecon.cpp
++++ b/interfaces/policycoreutils/src/hap_restorecon.cpp
+@@ -15,7 +15,8 @@
+ 
+ #include "hap_restorecon.h"
+ #include <fstream>
+-#include <include/fts.h>
++#include <fts.h>
++#include <sys/stat.h>
+ #include <regex>
+ #include <selinux/label.h>
+ #include <selinux/restorecon.h>
diff --git a/recipes-openharmony/openharmony/openharmony-standard-3.1/third_party_selinux-fts.patch b/recipes-openharmony/openharmony/openharmony-standard-3.1/third_party_selinux-fts.patch
new file mode 100644
index 0000000000000000000000000000000000000000..c765343157797317ccedee07830ec96f44e34c9c
--- /dev/null
+++ b/recipes-openharmony/openharmony/openharmony-standard-3.1/third_party_selinux-fts.patch
@@ -0,0 +1,53 @@
+# SPDX-FileCopyrightText: Huawei Inc.
+#
+# SPDX-License-Identifier: Apache-2.0
+
+Apply to //third_party/selinux of OpenHarmony 3.1 codebase.
+
+This removes the file fts.c from //third_party/FreeBSD and statically
+links with musl-fts library when building with the target toolchain
+(i.e. musl). When it builds with the native sysroot, it uses the fts
+APIs already supported by glibc.
+
+Signed-off-by: Thierry Escande <thierry.escande@huawei.com>
+Upstream-Status: Inappropriate
+
+diff --git a/BUILD.gn b/BUILD.gn
+index a8fb10db..cd3d3cdd 100644
+--- a/BUILD.gn
++++ b/BUILD.gn
+@@ -137,7 +137,6 @@ ohos_executable("chkcon") {
+ ohos_shared_library("libselinux") {
+   output_name = "libselinux"
+   sources = [
+-    "$LIBFTS_ROOT_DIR/lib/libc/gen/fts.c",
+     "$LIBSELINUX_ROOT_DIR/src/avc.c",
+     "$LIBSELINUX_ROOT_DIR/src/avc_internal.c",
+     "$LIBSELINUX_ROOT_DIR/src/avc_sidtab.c",
+@@ -214,6 +213,11 @@ ohos_shared_library("libselinux") {
+     "ramdisk",
+     "updater",
+   ]
++
++  if (current_toolchain != host_toolchain) {
++    ldflags = [ "../../oniro/sysroots/target/usr/lib/libfts.a" ]
++  }
++
+   license_file = "$LIBSELINUX_ROOT_DIR/LICENSE"
+   part_name = "selinux"
+   subsystem_name = "security"
+diff --git a/libselinux/src/selinux_restorecon.c b/libselinux/src/selinux_restorecon.c
+index e2553cda..099cf4e8 100644
+--- a/libselinux/src/selinux_restorecon.c
++++ b/libselinux/src/selinux_restorecon.c
+@@ -14,7 +14,7 @@
+ #include <ctype.h>
+ #include <errno.h>
+ #include <fcntl.h>
+-#include <include/fts.h>
++#include <fts.h>
+ #include <inttypes.h>
+ #include <limits.h>
+ #include <stdint.h>
+diff --git a/BUILD.gn b/BUILD.gn
+index a8fb10db..c7ece203 100644
diff --git a/recipes-openharmony/openharmony/openharmony-standard-sources-3.1.inc b/recipes-openharmony/openharmony/openharmony-standard-sources-3.1.inc
index d33706e703d3faa91fbae51113352b760b118a28..57693dcd39bb2bdeb9163d20e87392d2eeef47a3 100644
--- a/recipes-openharmony/openharmony/openharmony-standard-sources-3.1.inc
+++ b/recipes-openharmony/openharmony/openharmony-standard-sources-3.1.inc
@@ -50,6 +50,7 @@ SRC_URI += "${GITEE_URL}/security_deviceauth.git;protocol=https;nobranch=1;branc
 SRC_URI += "${GITEE_URL}/security_device_security_level.git;protocol=https;nobranch=1;branch=OpenHarmony-v3.1.1-Release;rev=a8326ac7a599d7638a592947888a72b4d076418f;destsuffix=${OH_SRCDIR}/base/security/device_security_level"
 SRC_URI += "${GITEE_URL}/security_huks.git;protocol=https;nobranch=1;branch=OpenHarmony-v3.1.1-Release;rev=e4f0c051cdbea87b93e9879ecac0efd5f2ebf75d;destsuffix=${OH_SRCDIR}/base/security/huks"
 SRC_URI += "${GITEE_URL}/security_permission.git;protocol=https;nobranch=1;branch=OpenHarmony-v3.1.1-Release;rev=807a32ca68f71834d54375d2f7eaf11f81a1127e;destsuffix=${OH_SRCDIR}/base/security/permission"
+SRC_URI += "${GITEE_URL}/security_selinux.git;protocol=https;nobranch=1;branch=OpenHarmony-v3.1.1-Release;rev=65c7a8741164f8fdead9f5cba52b7c2d32984d8d;destsuffix=${OH_SRCDIR}/base/security/selinux/"
 SRC_URI += "${GITEE_URL}/sensors_sensor.git;protocol=https;nobranch=1;branch=OpenHarmony-v3.1.1-Release;rev=54999891f299b412a9b0cdbfada6b61e33cd7110;destsuffix=${OH_SRCDIR}/base/sensors/sensor"
 SRC_URI += "${GITEE_URL}/startup_appspawn.git;protocol=https;nobranch=1;branch=OpenHarmony-v3.1.1-Release;rev=b7447b8f4f48598068ea5381f1a33905fe552214;destsuffix=${OH_SRCDIR}/base/startup/appspawn_standard"
 SRC_URI += "${GITEE_URL}/startup_init_lite.git;protocol=https;nobranch=1;branch=OpenHarmony-v3.1.1-Release;rev=5158c9ade29dda41a9a8466ba78d8d17ac007936;destsuffix=${OH_SRCDIR}/base/startup/init_lite"
@@ -150,6 +151,7 @@ SRC_URI += "${GITEE_URL}/third_party_libexif.git;protocol=https;nobranch=1;branc
 SRC_URI += "${GITEE_URL}/third_party_libffi.git;protocol=https;nobranch=1;branch=OpenHarmony-v3.1.1-Release;rev=66962913be641f90546c5a69e2abd17c35068e4d;destsuffix=${OH_SRCDIR}/third_party/libffi"
 SRC_URI += "${GITEE_URL}/third_party_libinput.git;protocol=https;nobranch=1;branch=OpenHarmony-v3.1.1-Release;rev=c2191e5259eb2b97944905abd8c28efdcd96fea0;destsuffix=${OH_SRCDIR}/third_party/libinput"
 SRC_URI += "${GITEE_URL}/third_party_libjpeg.git;protocol=https;nobranch=1;branch=OpenHarmony-v3.1.1-Release;rev=064bfd10e9cf7ee82c1f5c67e4872aa2fa44f71c;destsuffix=${OH_SRCDIR}/third_party/libjpeg"
+SRC_URI += "${GITEE_URL}/third_party_libnl.git;protocol=https;nobranch=1;branch=OpenHarmony-v3.1.1-Release;rev=3fd37ca55113ce0651aadce2384521882c86667c;destsuffix=${OH_SRCDIR}/third_party/libnl"
 SRC_URI += "${GITEE_URL}/third_party_libphonenumber.git;protocol=https;nobranch=1;branch=OpenHarmony-v3.1.1-Release;rev=21585c1eac7518b8360dd4652e45bca0c4a94018;destsuffix=${OH_SRCDIR}/third_party/libphonenumber;lfs=0"
 SRC_URI += "${GITEE_URL}/third_party_libpng.git;protocol=https;nobranch=1;branch=OpenHarmony-v3.1.1-Release;rev=f9775057a8bc3b99fedc687e2a2f3b06dec60487;destsuffix=${OH_SRCDIR}/third_party/libpng"
 SRC_URI += "${GITEE_URL}/third_party_libpsl.git;protocol=https;nobranch=1;branch=OpenHarmony-v3.1.1-Release;rev=c2e76526c400448f9474d480bd5ba7f846babf1f;destsuffix=${OH_SRCDIR}/third_party/libpsl"
diff --git a/recipes-openharmony/openharmony/openharmony-standard_3.1.bb b/recipes-openharmony/openharmony/openharmony-standard_3.1.bb
index eddcc674cd680a8a83b9d0b767f457db96d78e6c..4cdea2f12aa775fb994d1c04fb2edca7c0fda868 100644
--- a/recipes-openharmony/openharmony/openharmony-standard_3.1.bb
+++ b/recipes-openharmony/openharmony/openharmony-standard_3.1.bb
@@ -18,6 +18,8 @@ DEPENDS += "ruby-native"
 DEPENDS += "hapsigner-native"
 DEPENDS += "packing-tool-native"
 
+DEPENDS += "fts"
+
 FILESEXTRAPATHS:prepend := "${THISDIR}/openharmony-${OPENHARMONY_VERSION}:"
 FILESEXTRAPATHS:prepend := "${THISDIR}/openharmony-standard-${OPENHARMONY_VERSION}:"
 
@@ -68,6 +70,8 @@ SRC_URI += "file://third_party_weston-hdi-display-layer.patch;patchdir=${S}/thir
 SRC_URI += "file://third_party_selinux-flex-bison-path.patch;patchdir=${S}/third_party/selinux"
 SRC_URI += "file://foundation_graphic_standard-flexlexer-h.patch;patchdir=${S}/foundation/graphic/standard"
 SRC_URI += "file://features.json;subdir=${OHOS_BUILD_CONFIGS_DIR}"
+SRC_URI += "file://third_party_selinux-fts.patch;patchdir=${S}/third_party/selinux"
+SRC_URI += "file://base_security_selinux-fts.patch;patchdir=${S}/base/security/selinux"
 
 # Patch to allow /system/profile and /system/usr to be symlinks to /usr/lib/openharmony
 SRC_URI += "file://foundation_distributedschedule_safwk-slash-system-symlink.patch;patchdir=${S}/foundation/distributedschedule/safwk"
@@ -202,6 +206,8 @@ do_install () {
     # Workaround! Build system does not install libcrypto.z.so (boringssl), so
     # we install it manually for now
     cp ${B}/developtools/profiler/libcrypto.z.so ${D}${libdir}/
+    # Same for libusb_shared.z.so
+    cp ${B}/common/common/libusb_shared.z.so ${D}${libdir}/
 }
 
 inherit update-alternatives
@@ -307,6 +313,8 @@ OPENHARMONY_PARTS += "developtools:bytrace_standard"
 OPENHARMONY_PARTS += "developtools:hdc_standard"
 OPENHARMONY_PARTS += "deviceprofile:device_profile_core"
 OPENHARMONY_PARTS += "distributeddatamgr:distributeddatamgr"
+OPENHARMONY_PARTS += "distributeddatamgr:distributedfilejs"
+OPENHARMONY_PARTS += "distributeddatamgr:e2fsprogs"
 OPENHARMONY_PARTS += "distributeddatamgr:native_appdatamgr"
 OPENHARMONY_PARTS += "distributedhardware:device_manager_base"
 OPENHARMONY_PARTS += "distributedschedule:dmsfwk_standard"
@@ -316,6 +324,8 @@ OPENHARMONY_PARTS += "filemanagement:storage_service"
 OPENHARMONY_PARTS += "global:i18n_standard"
 OPENHARMONY_PARTS += "global:resmgr_standard"
 OPENHARMONY_PARTS += "graphic:graphic_standard"
+OPENHARMONY_PARTS += "hdf:audio_device_driver"
+OPENHARMONY_PARTS += "hdf:battery_device_driver"
 OPENHARMONY_PARTS += "hdf:device_driver_framework"
 OPENHARMONY_PARTS += "hdf:hdf"
 OPENHARMONY_PARTS += "hdf:mocks"
@@ -337,6 +347,7 @@ OPENHARMONY_PARTS += "hiviewdfx:hitrace_native"
 OPENHARMONY_PARTS += "hiviewdfx:hiviewdfx_hilog_native"
 OPENHARMONY_PARTS += "miscservices:inputmethod_native"
 OPENHARMONY_PARTS += "miscservices:time_native"
+OPENHARMONY_PARTS += "msdp:device_status"
 OPENHARMONY_PARTS += "multimedia:multimedia_audio_standard"
 OPENHARMONY_PARTS += "multimedia:multimedia_camera_standard"
 OPENHARMONY_PARTS += "multimedia:multimedia_histreamer"
@@ -357,15 +368,22 @@ OPENHARMONY_PARTS += "security:deviceauth_standard"
 OPENHARMONY_PARTS += "security:device_security_level"
 OPENHARMONY_PARTS += "security:huks"
 OPENHARMONY_PARTS += "security:permission_standard"
+OPENHARMONY_PARTS += "security:selinux"
 OPENHARMONY_PARTS += "sensors:sensor"
 OPENHARMONY_PARTS += "startup:appspawn"
 OPENHARMONY_PARTS += "startup:init"
 OPENHARMONY_PARTS += "startup:startup_l2"
 OPENHARMONY_PARTS += "telephony:core_service"
 OPENHARMONY_PARTS += "telephony:ril_adapter"
+OPENHARMONY_PARTS += "usb:libusb_shared"
+OPENHARMONY_PARTS += "useriam:auth_executor_mgr"
+OPENHARMONY_PARTS += "useriam:pin_auth"
+OPENHARMONY_PARTS += "useriam:user_auth"
 OPENHARMONY_PARTS += "useriam:user_idm"
+OPENHARMONY_PARTS += "useriam:useriam_common"
 OPENHARMONY_PARTS += "utils:utils_base"
 OPENHARMONY_PARTS += "window:window_manager"
+OPENHARMONY_PARTS += "wpa_supplicant-2.9:wpa_supplicant-2.9"
 
 python generate_parts_json() {
     # parts.json file is used by the loader.py tool to generate BUILD.gn files
@@ -812,13 +830,6 @@ do_install_ptest:append() {
 
 EXCLUDE_FROM_SHLIBS = "1"
 
-# FIXME: this is a dirty workaround for a bunch of missing *.z.so files, either
-# from parts we need to install, or some problems with "inner kits" not being
-# installed to our image. These are most likely real problems that we need to
-# fix, as the components needing these will most likely fail in all kinds of
-# wonderful ways.
-INSANE_SKIP:${PN} = "file-rdeps"
-
 # To avoid excessive diskspace blowup, we are stripping our executables
 INSANE_SKIP:${PN} += "already-stripped"
 
diff --git a/recipes-openharmony/prebuilts/oniro-openharmony-toolchain-integration-3.1.inc b/recipes-openharmony/prebuilts/oniro-openharmony-toolchain-integration-3.1.inc
index e9883c246f8902395d031fdbb7b7fd18bf90af17..de5b33a122d64abb3549d7f3a9569c99872f7d9a 100644
--- a/recipes-openharmony/prebuilts/oniro-openharmony-toolchain-integration-3.1.inc
+++ b/recipes-openharmony/prebuilts/oniro-openharmony-toolchain-integration-3.1.inc
@@ -16,3 +16,4 @@ SRC_URI += "file://patches/productdefine_common.patch;apply=no;subdir=src"
 SRC_URI += "file://patches/third_party_libevdev.patch;apply=no;subdir=src"
 SRC_URI += "file://patches/third_party_libusb.patch;apply=no;subdir=src"
 SRC_URI += "file://patches/third_party_e2fsprogs-backports-to-3.1.patch;apply=no;subdir=src"
+SRC_URI += "file://patches/third_party_selinux.patch;apply=no;subdir=src"
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/third_party_selinux.patch b/recipes-openharmony/prebuilts/openharmony-3.1/patches/third_party_selinux.patch
new file mode 100644
index 0000000000000000000000000000000000000000..73085d39bdf610f763fe2fe44db01daffd76031f
--- /dev/null
+++ b/recipes-openharmony/prebuilts/openharmony-3.1/patches/third_party_selinux.patch
@@ -0,0 +1,29 @@
+# SPDX-FileCopyrightText: Huawei Inc.
+#
+# SPDX-License-Identifier: Apache-2.0
+
+Patch for //third_party/selinux git repository of OpenHarmony 3.1 codebase.
+
+This disables the _FORTIFY_SOURCE macro for native build with gcc.
+This fixes the following compiler error for libselinux:
+ "error: inlining failed in call to always_inline ‘syslog’: function body can be overwritten at link time"
+
+Signed-off-by: Thierry Escande <thierry.escande@huawei.com>
+Upstream-Status: Inappropriate
+
+diff --git a/third_party/selinux/BUILD.gn b/third_party/selinux/BUILD.gn
+index 34616600..a9ca7cf5 100644
+--- a/third_party/selinux/BUILD.gn
++++ b/third_party/selinux/BUILD.gn
+@@ -199,6 +199,11 @@ ohos_shared_library("libselinux") {
+     "-DAUDITD_LOG_TAG=1003",
+     "-DPCRE2_CODE_UNIT_WIDTH=8",
+   ]
++
++  if (!is_clang) {
++    cflags += [ "-U_FORTIFY_SOURCE" ]
++  }
++
+   deps = [
+     ":libsepol",
+     "$LIBPCRE2_ROOT_DIR:libpcre2",