diff --git a/recipes-openharmony/prebuilts/oniro-openharmony-target-integration.bb b/recipes-openharmony/prebuilts/oniro-openharmony-target-integration.bb
index f0523e8f7c4879897481d7a91c53f8987d6eadd7..4f83433d6635d0beb3ea9b021307e417fa9d87c8 100644
--- a/recipes-openharmony/prebuilts/oniro-openharmony-target-integration.bb
+++ b/recipes-openharmony/prebuilts/oniro-openharmony-target-integration.bb
@@ -6,6 +6,8 @@ SUMMARY = "Target specific integration of Oniro toolchain into OpenHarmony"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM += "file://BUILD_target.gn;beginline=1;endline=3;md5=a1537856660cf2c8e36079c007b35bec"
 
+require sanity-check.inc
+
 S = "${WORKDIR}"
 B = "${WORKDIR}/build"
 
diff --git a/recipes-openharmony/prebuilts/oniro-openharmony-thirdparty-integration.bb b/recipes-openharmony/prebuilts/oniro-openharmony-thirdparty-integration.bb
index 8bda389afcd6e6acfe6d6e6490b7014a84a5f606..6ae1825c77d23a50540d35cb83dcbec1601057b2 100644
--- a/recipes-openharmony/prebuilts/oniro-openharmony-thirdparty-integration.bb
+++ b/recipes-openharmony/prebuilts/oniro-openharmony-thirdparty-integration.bb
@@ -6,6 +6,8 @@ SUMMARY = "Integration of Oniro 3rd party components into OpenHarmony"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://overlay/third_party/openssl/BUILD.gn;beginline=1;endline=3;md5=a1537856660cf2c8e36079c007b35bec"
 
+require sanity-check.inc
+
 BBCLASSEXTEND = "native nativesdk"
 
 INHIBIT_DEFAULT_DEPS = "1"
@@ -21,7 +23,8 @@ SRC_URI += "file://patches/build_third_party.patch;apply=no;subdir=src"
 
 SRC_URI += "file://third_party/openssl/BUILD.gn;subdir=src/overlay"
 
-require oniro-openharmony-thirdparty-integration-${OPENHARMONY_VERSION}.inc
+# Note: Using include instead of require to avoid parser error skipping recipe
+include oniro-openharmony-thirdparty-integration-${OPENHARMONY_VERSION}.inc
 
 do_install() {
     mkdir -p ${D}${datadir}/oniro-openharmony
diff --git a/recipes-openharmony/prebuilts/oniro-openharmony-toolchain-integration.bb b/recipes-openharmony/prebuilts/oniro-openharmony-toolchain-integration.bb
index 456055d4c6ea509ae55a0fdef1cf482c66322eca..00d0a223a64030603739fdd50462136cfe577e4f 100644
--- a/recipes-openharmony/prebuilts/oniro-openharmony-toolchain-integration.bb
+++ b/recipes-openharmony/prebuilts/oniro-openharmony-toolchain-integration.bb
@@ -6,6 +6,8 @@ SUMMARY = "Integration of Oniro toolchain into OpenHarmony"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://setup.sh;beginline=3;endline=15;md5=306e15e328d14d4055327f82b55064a0"
 
+require sanity-check.inc
+
 BBCLASSEXTEND = "native nativesdk"
 
 INHIBIT_DEFAULT_DEPS = "1"
@@ -43,7 +45,8 @@ SRC_URI += "file://build/common/musl/BUILD.gn;subdir=src/overlay"
 
 SRC_URI += "file://BUILD_host.gn"
 
-require oniro-openharmony-toolchain-integration-${OPENHARMONY_VERSION}.inc
+# Note: Using include instead of require to avoid parser error skipping recipe
+include oniro-openharmony-toolchain-integration-${OPENHARMONY_VERSION}.inc
 
 SDK_DYNAMIC_LINKER:x86-64  = "ld-linux-x86-64.so.2"
 SDK_DYNAMIC_LINKER:x86     = "ld-linux.so.2"
diff --git a/recipes-openharmony/prebuilts/oniro-openharmony-toolchain.bb b/recipes-openharmony/prebuilts/oniro-openharmony-toolchain.bb
index 04780b7f311bbf0862d4ece3faa61a1282de4cfb..c010164c18aeae2a11d35d66adf7b83d415608ff 100644
--- a/recipes-openharmony/prebuilts/oniro-openharmony-toolchain.bb
+++ b/recipes-openharmony/prebuilts/oniro-openharmony-toolchain.bb
@@ -13,6 +13,8 @@ with bitbake. Recipes building OpenHarmony with bitbake should depend on this \
 recipe, and will need to hook in the recipe-sysroot and recipe-sysroot-native \
 folders before building."
 
+require sanity-check.inc
+
 inherit populate_sdk
 
 TOOLCHAIN_OUTPUTNAME = "${PN}-${OPENHARMONY_VERSION}-${TUNE_PKGARCH}-${SDK_VERSION}"
diff --git a/recipes-openharmony/prebuilts/sanity-check.inc b/recipes-openharmony/prebuilts/sanity-check.inc
new file mode 100644
index 0000000000000000000000000000000000000000..bba5400419912d2be181e6bab413cb565b58e91c
--- /dev/null
+++ b/recipes-openharmony/prebuilts/sanity-check.inc
@@ -0,0 +1,7 @@
+# SPDX-FileCopyrightText: Huawei Inc.
+#
+# SPDX-License-Identifier: Apache-2.0
+
+# Skip recipe if openharmony is not in DISTRO_FEATURES
+inherit features_check
+REQUIRED_DISTRO_FEATURES = "openharmony"