diff --git a/recipes-openharmony/openharmony/openharmony-standard-3.0/ace_engine-disable-create-component.patch b/recipes-openharmony/openharmony/openharmony-standard-3.0/ace_engine-disable-create-component.patch
new file mode 100644
index 0000000000000000000000000000000000000000..1197b21483a3540b5ab8d68102555af7f682b45f
--- /dev/null
+++ b/recipes-openharmony/openharmony/openharmony-standard-3.0/ace_engine-disable-create-component.patch
@@ -0,0 +1,29 @@
+# SPDX-FileCopyrightText: Huawei Inc.
+#
+# SPDX-License-Identifier: Apache-2.0
+
+foundation/ace/ace_engine: disable graphics
+
+The graphics rendering is slowing the system making some ACTS test suites to timeout.
+Since we are aiming for certification for headless system, graphics stack 
+should not be required.
+Disabling graphics by skipping JSView::CreateComponent() execution.
+In the future we will remove this patch when we the graphical part will be needed.
+
+Apply to foundation/ace/ace_engine
+
+Upstream-Status: Inappropriate
+
+Signed-off-by: Francesco Pham <francesco.pham@huawei.com>
+diff --git a/frameworks/bridge/declarative_frontend/jsview/js_view.cpp b/frameworks/bridge/declarative_frontend/jsview/js_view.cpp
+index e455cb00..d58d5c79 100644
+--- a/frameworks/bridge/declarative_frontend/jsview/js_view.cpp
++++ b/frameworks/bridge/declarative_frontend/jsview/js_view.cpp
+@@ -254,6 +254,7 @@ RefPtr<OHOS::Ace::Component> JSView::CreateComponent()
+ 
+     std::string key = ViewStackProcessor::GetInstance()->ProcessViewId(viewId_);
+     auto composedComponent = AceType::MakeRefPtr<ComposedComponent>(key, "view");
++    return composedComponent;
+ 
+     // add callback for element creation to component, and get pointer reference
+     // to the element on creation. When state of this view changes, mark the
diff --git a/recipes-openharmony/openharmony/openharmony-standard_3.0.bb b/recipes-openharmony/openharmony/openharmony-standard_3.0.bb
index d391328d04d6f42e5ea099c5fe1dad083e4b012e..003bcc2a381b17960981224f489b886a652c56da 100644
--- a/recipes-openharmony/openharmony/openharmony-standard_3.0.bb
+++ b/recipes-openharmony/openharmony/openharmony-standard_3.0.bb
@@ -97,6 +97,7 @@ SRC_URI += "file://foundation_distributedschedule_safwk-slash-system-symlink.pat
 SRC_URI += "file://test-xts-acts-fix-Defpermission-typo.patch;patchdir=${S}/test/xts/acts"
 SRC_URI += "file://test-xts-acts-fix-faultloggertest.patch;patchdir=${S}/test/xts/acts"
 SRC_URI += "file://test-xts-acts-fix-hicolliecpptest.patch;patchdir=${S}/test/xts/acts"
+SRC_URI += "file://ace_engine-disable-create-component.patch;patchdir=${S}/foundation/ace/ace_engine"
 SRC_URI += "file://test-xts-acts-increase-testsuite-timeouts.patch;patchdir=${S}/test/xts/acts"
 SRC_URI += "file://foundation_ace_engine-race-condition-workaround.patch;patchdir=${S}/foundation/ace/ace_engine"