diff --git a/recipes-openharmony/openharmony/files/deviceauth.service b/recipes-openharmony/openharmony/files/deviceauth.service
new file mode 100644
index 0000000000000000000000000000000000000000..09c7d1340449d8bed377026a9da5d5d17dbd13d4
--- /dev/null
+++ b/recipes-openharmony/openharmony/files/deviceauth.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=OpenHarmony Device Authentication daemon
+Requires=samgr.service
+After=samgr.service
+
+[Service]
+Type=exec
+# Delay execution by 2 secs after samgr.service
+ExecStartPre=/bin/sleep 2
+ExecStart=/usr/bin/deviceauth_service
+
+[Install]
+WantedBy=multi-user.target
diff --git a/recipes-openharmony/openharmony/files/deviceauth.service.license b/recipes-openharmony/openharmony/files/deviceauth.service.license
new file mode 100644
index 0000000000000000000000000000000000000000..98a0b3f4a5b8db268215a128c7d06e0a10897e73
--- /dev/null
+++ b/recipes-openharmony/openharmony/files/deviceauth.service.license
@@ -0,0 +1,3 @@
+# SPDX-FileCopyrightText: Huawei Inc.
+#
+# SPDX-License-Identifier: Apache-2.0
diff --git a/recipes-openharmony/openharmony/openharmony-standard_3.0.bb b/recipes-openharmony/openharmony/openharmony-standard_3.0.bb
index ac628db588c78b208a6f19253089e5ac9fd4cf53..3f67a774875878b240bb5a319f8b23c8b2ef8325 100644
--- a/recipes-openharmony/openharmony/openharmony-standard_3.0.bb
+++ b/recipes-openharmony/openharmony/openharmony-standard_3.0.bb
@@ -926,6 +926,14 @@ RDEPENDS:${PN}-ptest += "${PN}-security-huks-ptest"
 
 # //base/security/deviceauth
 PACKAGES =+ "${PN}-security-deviceauth"
+SYSTEMD_PACKAGES += "${PN}-security-deviceauth"
+SYSTEMD_SERVICE:${PN}-security-deviceauth = "deviceauth.service"
+SRC_URI += "file://deviceauth.service"
+do_install:append() {
+    install -d ${D}/${systemd_unitdir}/system
+    install -m 644 ${WORKDIR}/deviceauth.service ${D}${systemd_unitdir}/system/
+    rm -f ${D}${sysconfdir}/openharmony/init/deviceauth_service.cfg
+}
 FILES:${PN}-security-deviceauth = " \
     ${bindir}/deviceauth_service \
     ${libdir}/libdeviceauth*${SOLIBS} \