diff --git a/recipes-openharmony/openharmony/files/40-ashmem.rules b/recipes-openharmony/openharmony/files/40-ashmem.rules
new file mode 100644
index 0000000000000000000000000000000000000000..6bea00b8b13e36f4649e1d10193e81230802c1de
--- /dev/null
+++ b/recipes-openharmony/openharmony/files/40-ashmem.rules
@@ -0,0 +1 @@
+KERNEL=="ashmem", MODE="0666"
diff --git a/recipes-openharmony/openharmony/files/40-binder.rules b/recipes-openharmony/openharmony/files/40-binder.rules
new file mode 100644
index 0000000000000000000000000000000000000000..b7ad4d957e651f867d8b28bfd7390376584bc507
--- /dev/null
+++ b/recipes-openharmony/openharmony/files/40-binder.rules
@@ -0,0 +1 @@
+KERNEL=="binder*", MODE="0666"
diff --git a/recipes-openharmony/openharmony/files/openharmony-preinit b/recipes-openharmony/openharmony/files/openharmony-preinit
index 8bcfaa9ad1449e5da7775d7d8134ebee797ccdfd..cac8b97f36066dddc19cc4bab38173710cef7117 100644
--- a/recipes-openharmony/openharmony/files/openharmony-preinit
+++ b/recipes-openharmony/openharmony/files/openharmony-preinit
@@ -83,10 +83,6 @@ mkdir -p /usr/lib/dri
 
 chmod -R 777 /data
 
-# /dev/binder and /dev/ashmem need to be rw for all users
-chmod 666 /dev/binder
-chmod 666 /dev/ashmem
-
 # /dev/dri/card0 needs to be rw for all users
 if [ -c /dev/dri/card0 ]; then
 	chmod 666 /dev/dri/card0
diff --git a/recipes-openharmony/openharmony/openharmony-standard_3.0.bb b/recipes-openharmony/openharmony/openharmony-standard_3.0.bb
index c1bfbe4b859b69bc43d1a0b953fee304e963a1e2..fdb0b5e4a48cd478219516f89671d50a451d6f24 100644
--- a/recipes-openharmony/openharmony/openharmony-standard_3.0.bb
+++ b/recipes-openharmony/openharmony/openharmony-standard_3.0.bb
@@ -413,6 +413,16 @@ copy_subsystem_config_json_file() {
 inherit systemd
 SYSTEMD_AUTO_ENABLE = "enable"
 
+SRC_URI += "file://40-binder.rules"
+SRC_URI += "file://40-ashmem.rules"
+do_install_udev_rules() {
+    mkdir -p ${D}${nonarch_base_libdir}/udev/rules.d
+    install -m 644 -t ${D}${nonarch_base_libdir}/udev/rules.d \
+            ${WORKDIR}/40-binder.rules \
+            ${WORKDIR}/40-ashmem.rules
+}
+do_install[postfuncs] += "do_install_udev_rules"
+
 # OpenHarmony pre-init package and its systemd service
 # Used to create folders needed by OH services and components
 PACKAGES =+ "${PN}-openharmony-preinit"