From a1bb6d9ef6228d5a727ae1d324b1dc31ce5e0582 Mon Sep 17 00:00:00 2001
From: Francesco Pham <francesco.pham@huawei.com>
Date: Thu, 10 Mar 2022 15:32:41 +0100
Subject: [PATCH] linux-yocto: Enable Android Binder ipc in linux-yocto

Some openharmony components (such as System Abilities) require Android
Binder ipc enabled in the kernel

Signed-off-by: Francesco Pham <francesco.pham@huawei.com>
---
 .../linux-yocto/linux-yocto/android_binder_ipc.cfg         | 7 +++++++
 recipes-kernel/linux-yocto/linux-yocto_%.bbappend          | 1 +
 2 files changed, 8 insertions(+)
 create mode 100644 recipes-kernel/linux-yocto/linux-yocto/android_binder_ipc.cfg

diff --git a/recipes-kernel/linux-yocto/linux-yocto/android_binder_ipc.cfg b/recipes-kernel/linux-yocto/linux-yocto/android_binder_ipc.cfg
new file mode 100644
index 00000000..413ab134
--- /dev/null
+++ b/recipes-kernel/linux-yocto/linux-yocto/android_binder_ipc.cfg
@@ -0,0 +1,7 @@
+# SPDX-FileCopyrightText: Huawei Inc.
+#
+# SPDX-License-Identifier: Apache-2.0
+
+CONFIG_ANDROID=y
+CONFIG_ANDROID_BINDER_IPC=y
+CONFIG_ANDROID_BINDER_DEVICES=binder,hwbinder,vndbinder
diff --git a/recipes-kernel/linux-yocto/linux-yocto_%.bbappend b/recipes-kernel/linux-yocto/linux-yocto_%.bbappend
index 284d90b2..ee2b9c76 100644
--- a/recipes-kernel/linux-yocto/linux-yocto_%.bbappend
+++ b/recipes-kernel/linux-yocto/linux-yocto_%.bbappend
@@ -7,3 +7,4 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/linux-yocto:"
 SRC_URI:append:oniro-openharmony-linux = " file://ashmem.cfg"
 SRC_URI:append:oniro-openharmony-linux = " file://driver-add-hilog-and-hievent-buffer-management-drive.patch"
 SRC_URI:append:oniro-openharmony-linux = " file://driver-add-hilog-and-hievent-buffer-management-drive.cfg"
+SRC_URI:append:oniro-openharmony-linux = " file://android_binder_ipc.cfg"
-- 
GitLab