From 92dd81be604fe72373e8cc7f93745a1d64f16693 Mon Sep 17 00:00:00 2001
From: Thierry Escande <thierry.escande@huawei.com>
Date: Thu, 30 Jun 2022 16:30:39 +0200
Subject: [PATCH] hapsigner: Inherit native class last

The native class must be inherited last, otherwise bitbake issues a
warning stating that it can have unpredictable effects.

Signed-off-by: Thierry Escande <thierry.escande@huawei.com>
---
 recipes-devtools/hapsigner/hapsigner-native_1.0.0.bb | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/recipes-devtools/hapsigner/hapsigner-native_1.0.0.bb b/recipes-devtools/hapsigner/hapsigner-native_1.0.0.bb
index 92283780..fb9b9fdf 100644
--- a/recipes-devtools/hapsigner/hapsigner-native_1.0.0.bb
+++ b/recipes-devtools/hapsigner/hapsigner-native_1.0.0.bb
@@ -6,8 +6,6 @@ SUMMARY = "HAP signer tool"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
-inherit native
-
 S = "${WORKDIR}/src"
 
 SRC_URI = "git://gitee.com/openharmony/developtools_hapsigner.git;protocol=http;branch=OpenHarmony-3.1-Release;rev=ff2cf76f14f7d6c6fa55c9d0f02c4c1eb9c795a9;destsuffix=${S}"
@@ -33,3 +31,6 @@ do_install() {
 	install -m 0644 dist/OpenHarmony.p12 ${D}/${DSTDIR}/
 	install -m 0644 dist/OpenHarmonyApplication.pem ${D}/${DSTDIR}/
 }
+
+# native class must be inherited last
+inherit native
-- 
GitLab