diff --git a/docs/definitions.rst b/docs/definitions.rst
new file mode 100644
index 0000000000000000000000000000000000000000..140ab22a067334040061bd8fcd2cd406aec3555e
--- /dev/null
+++ b/docs/definitions.rst
@@ -0,0 +1,4 @@
+.. SPDX-FileCopyrightText: Huawei Inc.
+..
+.. SPDX-License-Identifier: CC-BY-4.0
+.. |main_project_name| replace:: Oniro Project
diff --git a/docs/supported-technologies/openharmony-image.rst b/docs/supported-technologies/openharmony-image.rst
new file mode 100644
index 0000000000000000000000000000000000000000..e527c5038f43dfc5aa9dd6dcb3e1b50d07a76424
--- /dev/null
+++ b/docs/supported-technologies/openharmony-image.rst
@@ -0,0 +1,14 @@
+.. SPDX-FileCopyrightText: Huawei Inc.
+..
+.. SPDX-License-Identifier: CC-BY-4.0
+
+.. include:: ../definitions.rst
+
+OpenHarmony Image
+#################
+
+Oniro Project can include OpenHarmony compatibility in the predefined images by
+enabling `openharmony` distro feature and adding it to the images.
+
+See :ref:`Building with OpenHarmony compatibility <Building with OpenHarmony>` in
+Quick Build instructions for details on how to do this.
diff --git a/docs/supported-technologies/openharmony-sdk.rst b/docs/supported-technologies/openharmony-sdk.rst
new file mode 120000
index 0000000000000000000000000000000000000000..92965293b048a2b12c8bf97b778c12398f707996
--- /dev/null
+++ b/docs/supported-technologies/openharmony-sdk.rst
@@ -0,0 +1 @@
+../../recipes-openharmony/sdk/README.rst
\ No newline at end of file
diff --git a/docs/supported-technologies/openharmony.rst b/docs/supported-technologies/openharmony.rst
new file mode 100644
index 0000000000000000000000000000000000000000..c2c28017e78c4cee9dc2a5334dfd900f642332c5
--- /dev/null
+++ b/docs/supported-technologies/openharmony.rst
@@ -0,0 +1,47 @@
+.. SPDX-FileCopyrightText: Huawei Inc.
+..
+.. SPDX-License-Identifier: CC-BY-4.0
+
+.. include:: ../definitions.rst
+
+OpenHarmony
+###########
+
+OpenHarmony is an open-source project incubated and operated by the OpenAtom
+Foundation. It is an open-source operating system with a framework and platform
+applicable to smart devices in all scenarios of a fully-connected world. It aims
+to promote the development of the Internet of Everything (IoE).
+
+OpenHarmony project provides a number of resources, including a Platform
+Compatibility Specification (PCS), a test suite (XTS) for verification of
+products and distributions following the PCS, and a complete reference
+implementation with support for several development boards.
+
+For more details on OpenHarmony project, `Click <https://gitee.com/openharmony>`__.
+
+|main_project_name| provides a number of different Yocto recipes related to
+OpenHarmony.
+
+``openharmony-standard``
+  builds OpenHarmony components from the OpenHarmony projects reference
+  implementation, for use in Oniro and other Yocto based projects.
+
+``oniro-openharmony-toolchain``
+  builds an LLVM toolchain for use with the OpenHarmony reference implementation
+  as a replacement for the default prebuilt toolchain.
+
+``oniro-openharmony-bundle``
+  is similar to the toolchain built with ``oniro-openharmony-toolchain``, but
+  with the addition of selected open-source 3rd party components, which replaces
+  the default versions of those same components provided in the OpenHarmony
+  reference implementation.
+
+``openharmony-standard-image``
+  builds a demo image, integrating the ``openharmony-standard`` output into a
+  bootable demo.
+
+.. toctree::
+   :maxdepth: 1
+
+   openharmony-image
+   openharmony-sdk
diff --git a/recipes-openharmony/prebuilts/README.md b/recipes-openharmony/prebuilts/README.md
deleted file mode 100644
index c0ac3dcf52c7c6e95b2caa8fd5992e0d4805621f..0000000000000000000000000000000000000000
--- a/recipes-openharmony/prebuilts/README.md
+++ /dev/null
@@ -1,55 +0,0 @@
-<!--
-SPDX-FileCopyrightText: Huawei Inc.
-
-SPDX-License-Identifier: CC-BY-4.0
--->
-
-# OpenHarmony prebuilts
-
-There are two different recipes providing a prebuilts for the OpenHarmony build system.
-
-The `oniro-openharmony-toolchain` recipe builds an image containing the Oniro
-Clang version and a musl libc version. The musl libc version is same upstream
-version as currently used in OpenHarmony, and is patched to be mostly identical
-to the musl libc version included in OpenHarmony build system.
-
-The `oniro-openharmony-bundle` recipe is a superset of
-`oniro-openharmony-toolchain`, adding Oniro third-party components on top.
-
-Using one of these images will replace OpenHarmony versions of the included
-OpenSource toolchain and third-party components with Oniro versions.
-
-## Usage
-
-To use one of the images produced with these recipes, you need to install it to
-an OpenHarmony source repository.
-
-Warning! It is recommended to only install OpenHarmony prebuilts to clean
-upstream OpenHarmony source repsitories, as the installation will remove files
-and entire git repositories!
-
-To install the `oniro-openharmony-bundle` to a clean OpenHarmony 3.0-LTS
-repository, you should do something like this:
-
-    tar xfz $DOWNLOADS/code-v3.1-Release.tar.gz
-    cd code-v3.1-Relase/OpenHarmony
-    $DOWNLOADS/oniro-openharmony-bundle-3.1-cortexa7-neon-vfpv4-1.99.99.sh -y -d oniro
-    ./oniro/setup.sh
-
-After this, you can use normal OpenHarmony build system procedures to build as
-usual.  To build image for HiSilicon Hi3516DV300 (taurus) board:
-
-    ./build.sh --product-name Hi3516DV300
-
-
-## Use inside BitBake
-
-**meta-openharmony** is a bitbake layer, containing recipes for building
-OpenHarmony software components.
-
-The meta-openharmony layer enables building of prebuilts for use with the
-OpenHarmony build system. A toolchain-only image, making it possible to use the
-Oniro Clang version instead of the default Clang version included, and a bundle
-image which contains both the Oniro Clang compiler and Oniro versions of various
-third-party components, replacing the corresponding default third-party
-versions.
diff --git a/recipes-openharmony/sdk/README.rst b/recipes-openharmony/sdk/README.rst
new file mode 100644
index 0000000000000000000000000000000000000000..287489ff18772e1485b1c27c5b00adb373a38aa0
--- /dev/null
+++ b/recipes-openharmony/sdk/README.rst
@@ -0,0 +1,90 @@
+.. SPDX-FileCopyrightText: Huawei Inc.
+..
+.. SPDX-License-Identifier: CC-BY-4.0
+
+.. _OpenHarmony SDK:
+
+OpenHarmony SDK
+###############
+
+Oniro Project provides support for building an alternative open-source toolchain
+for use with the OpenHarmony reference implementation. This allows using an
+updated Clang/LLVM compiler built from the meta-clang Yocto layer instead of the
+default prebuilt Clang/LLVM compiler provided by OpenHarmony project.
+
+There are two different Yocto recipes providing prebuilt SDK images for the
+OpenHarmony build system.
+
+``oniro-openharmony-toolchain``
+  The `oniro-openharmony-toolchain` recipe builds an image containing the Oniro
+  Clang version and a musl libc version. The musl libc version is same upstream
+  version as currently used in OpenHarmony, and is patched to exhibit the same
+  runtime behavior to the musl libc version included in OpenHarmony build
+  system.
+
+``oniro-openharmony-bundle``
+  The `oniro-openharmony-bundle` recipe is a superset of
+  `oniro-openharmony-toolchain`, adding third-party components on top using
+  Oniro (Yocto) recipes, replacing the corresponding third-party components
+  included in OpenHarmony repository.
+
+Using one of these images replaces then OpenHarmony versions of the included
+OpenSource toolchain and third-party components with newer Oniro versions.
+
+
+Building
+********
+
+To build `oniro-openharmony-bundle` for OpenHarmony 3.1.1, the `bitbake` command
+is simply::
+
+    DISTRO=oniro-openharmony-linux MACHINE=qemuarma7 bitbake oniro-openharmony-bundle
+
+In order to build for OpenHarmony 3.0.1 instead, you need to add the following
+line to the `build/conf/local.conf` file::
+
+    OPENHARMONY_VERSION = "3.0"
+
+And then use the same command as shown above for 3.1.1.
+
+To build `oniro-openharmony-toolchain` instead, simply use::
+
+    DISTRO=oniro-openharmony-linux MACHINE=qemuarma7 bitbake oniro-openharmony-toolchain
+
+
+Usage
+*****
+
+To use one of the images produced with these recipes, you need to install it to
+an OpenHarmony source repository.
+
+Warning! It is recommended to only install OpenHarmony prebuilts to clean
+upstream OpenHarmony source repsitories, as the installation will remove files
+and entire git repositories!
+
+To install the `oniro-openharmony-bundle` to a clean OpenHarmony 3.1.1
+repository, you should do something like this::
+
+    tar xfz $DOWNLOADS/code-v3.1.1-Release.tar.gz
+    cd code-v3.1-Relase/OpenHarmony
+    $DOWNLOADS/oniro-openharmony-bundle-3.1-cortexa7-neon-vfpv4-1.99.99.sh -y -d oniro
+    ./oniro/setup.sh
+
+After this, you can use normal OpenHarmony build system procedures to build as
+usual.  To build image for HiSilicon Hi3516DV300 (taurus) board::
+
+    ./build.sh --product-name Hi3516DV300
+
+
+Use inside BitBake
+******************
+
+**meta-openharmony** is a bitbake layer, containing recipes for building
+OpenHarmony software components.
+
+The meta-openharmony layer enables building of prebuilts for use with the
+OpenHarmony build system. A toolchain-only image, making it possible to use the
+Oniro Clang version instead of the default Clang version included, and a bundle
+image which contains both the Oniro Clang compiler and Oniro versions of various
+third-party components, replacing the corresponding default third-party
+versions.
diff --git a/recipes-openharmony/prebuilts/files/build/common/musl/BUILD.gn b/recipes-openharmony/sdk/files/build/common/musl/BUILD.gn
similarity index 100%
rename from recipes-openharmony/prebuilts/files/build/common/musl/BUILD.gn
rename to recipes-openharmony/sdk/files/build/common/musl/BUILD.gn
diff --git a/recipes-openharmony/prebuilts/files/patches/build_gcc-toolchain-gni.patch b/recipes-openharmony/sdk/files/patches/build_gcc-toolchain-gni.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/files/patches/build_gcc-toolchain-gni.patch
rename to recipes-openharmony/sdk/files/patches/build_gcc-toolchain-gni.patch
diff --git a/recipes-openharmony/prebuilts/files/relocate-ld-scripts.sh b/recipes-openharmony/sdk/files/relocate-ld-scripts.sh
similarity index 100%
rename from recipes-openharmony/prebuilts/files/relocate-ld-scripts.sh
rename to recipes-openharmony/sdk/files/relocate-ld-scripts.sh
diff --git a/recipes-openharmony/prebuilts/files/setup.sh b/recipes-openharmony/sdk/files/setup.sh
similarity index 100%
rename from recipes-openharmony/prebuilts/files/setup.sh
rename to recipes-openharmony/sdk/files/setup.sh
diff --git a/recipes-openharmony/prebuilts/files/third_party.gni b/recipes-openharmony/sdk/files/third_party.gni
similarity index 100%
rename from recipes-openharmony/prebuilts/files/third_party.gni
rename to recipes-openharmony/sdk/files/third_party.gni
diff --git a/recipes-openharmony/prebuilts/files/third_party/musl/BUILD.gn b/recipes-openharmony/sdk/files/third_party/musl/BUILD.gn
similarity index 100%
rename from recipes-openharmony/prebuilts/files/third_party/musl/BUILD.gn
rename to recipes-openharmony/sdk/files/third_party/musl/BUILD.gn
diff --git a/recipes-openharmony/prebuilts/files/third_party/musl/musl_config.gni b/recipes-openharmony/sdk/files/third_party/musl/musl_config.gni
similarity index 100%
rename from recipes-openharmony/prebuilts/files/third_party/musl/musl_config.gni
rename to recipes-openharmony/sdk/files/third_party/musl/musl_config.gni
diff --git a/recipes-openharmony/prebuilts/files/toolchain.gni b/recipes-openharmony/sdk/files/toolchain.gni
similarity index 100%
rename from recipes-openharmony/prebuilts/files/toolchain.gni
rename to recipes-openharmony/sdk/files/toolchain.gni
diff --git a/recipes-openharmony/prebuilts/oniro-openharmony-bundle.bb b/recipes-openharmony/sdk/oniro-openharmony-bundle.bb
similarity index 100%
rename from recipes-openharmony/prebuilts/oniro-openharmony-bundle.bb
rename to recipes-openharmony/sdk/oniro-openharmony-bundle.bb
diff --git a/recipes-openharmony/prebuilts/oniro-openharmony-target-integration.bb b/recipes-openharmony/sdk/oniro-openharmony-target-integration.bb
similarity index 100%
rename from recipes-openharmony/prebuilts/oniro-openharmony-target-integration.bb
rename to recipes-openharmony/sdk/oniro-openharmony-target-integration.bb
diff --git a/recipes-openharmony/prebuilts/oniro-openharmony-thirdparty-integration-3.0.inc b/recipes-openharmony/sdk/oniro-openharmony-thirdparty-integration-3.0.inc
similarity index 100%
rename from recipes-openharmony/prebuilts/oniro-openharmony-thirdparty-integration-3.0.inc
rename to recipes-openharmony/sdk/oniro-openharmony-thirdparty-integration-3.0.inc
diff --git a/recipes-openharmony/prebuilts/oniro-openharmony-thirdparty-integration-3.1.inc b/recipes-openharmony/sdk/oniro-openharmony-thirdparty-integration-3.1.inc
similarity index 100%
rename from recipes-openharmony/prebuilts/oniro-openharmony-thirdparty-integration-3.1.inc
rename to recipes-openharmony/sdk/oniro-openharmony-thirdparty-integration-3.1.inc
diff --git a/recipes-openharmony/prebuilts/oniro-openharmony-thirdparty-integration.bb b/recipes-openharmony/sdk/oniro-openharmony-thirdparty-integration.bb
similarity index 100%
rename from recipes-openharmony/prebuilts/oniro-openharmony-thirdparty-integration.bb
rename to recipes-openharmony/sdk/oniro-openharmony-thirdparty-integration.bb
diff --git a/recipes-openharmony/prebuilts/oniro-openharmony-toolchain-integration-3.0.inc b/recipes-openharmony/sdk/oniro-openharmony-toolchain-integration-3.0.inc
similarity index 100%
rename from recipes-openharmony/prebuilts/oniro-openharmony-toolchain-integration-3.0.inc
rename to recipes-openharmony/sdk/oniro-openharmony-toolchain-integration-3.0.inc
diff --git a/recipes-openharmony/prebuilts/oniro-openharmony-toolchain-integration-3.1.inc b/recipes-openharmony/sdk/oniro-openharmony-toolchain-integration-3.1.inc
similarity index 100%
rename from recipes-openharmony/prebuilts/oniro-openharmony-toolchain-integration-3.1.inc
rename to recipes-openharmony/sdk/oniro-openharmony-toolchain-integration-3.1.inc
diff --git a/recipes-openharmony/prebuilts/oniro-openharmony-toolchain-integration.bb b/recipes-openharmony/sdk/oniro-openharmony-toolchain-integration.bb
similarity index 100%
rename from recipes-openharmony/prebuilts/oniro-openharmony-toolchain-integration.bb
rename to recipes-openharmony/sdk/oniro-openharmony-toolchain-integration.bb
diff --git a/recipes-openharmony/prebuilts/oniro-openharmony-toolchain.bb b/recipes-openharmony/sdk/oniro-openharmony-toolchain.bb
similarity index 100%
rename from recipes-openharmony/prebuilts/oniro-openharmony-toolchain.bb
rename to recipes-openharmony/sdk/oniro-openharmony-toolchain.bb
diff --git a/recipes-openharmony/prebuilts/openharmony-3.0/BUILD.gn b/recipes-openharmony/sdk/openharmony-3.0/BUILD.gn
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.0/BUILD.gn
rename to recipes-openharmony/sdk/openharmony-3.0/BUILD.gn
diff --git a/recipes-openharmony/prebuilts/openharmony-3.0/BUILD_host.gn b/recipes-openharmony/sdk/openharmony-3.0/BUILD_host.gn
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.0/BUILD_host.gn
rename to recipes-openharmony/sdk/openharmony-3.0/BUILD_host.gn
diff --git a/recipes-openharmony/prebuilts/openharmony-3.0/BUILD_target.gn b/recipes-openharmony/sdk/openharmony-3.0/BUILD_target.gn
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.0/BUILD_target.gn
rename to recipes-openharmony/sdk/openharmony-3.0/BUILD_target.gn
diff --git a/recipes-openharmony/prebuilts/openharmony-3.0/patches/ace_ace_engine.patch b/recipes-openharmony/sdk/openharmony-3.0/patches/ace_ace_engine.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.0/patches/ace_ace_engine.patch
rename to recipes-openharmony/sdk/openharmony-3.0/patches/ace_ace_engine.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.0/patches/ark_js_runtime.patch b/recipes-openharmony/sdk/openharmony-3.0/patches/ark_js_runtime.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.0/patches/ark_js_runtime.patch
rename to recipes-openharmony/sdk/openharmony-3.0/patches/ark_js_runtime.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.0/patches/ark_runtime_core.patch b/recipes-openharmony/sdk/openharmony-3.0/patches/ark_runtime_core.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.0/patches/ark_runtime_core.patch
rename to recipes-openharmony/sdk/openharmony-3.0/patches/ark_runtime_core.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.0/patches/ark_ts2abc.patch b/recipes-openharmony/sdk/openharmony-3.0/patches/ark_ts2abc.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.0/patches/ark_ts2abc.patch
rename to recipes-openharmony/sdk/openharmony-3.0/patches/ark_ts2abc.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.0/patches/build-ninja_args.patch b/recipes-openharmony/sdk/openharmony-3.0/patches/build-ninja_args.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.0/patches/build-ninja_args.patch
rename to recipes-openharmony/sdk/openharmony-3.0/patches/build-ninja_args.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.0/patches/build.patch b/recipes-openharmony/sdk/openharmony-3.0/patches/build.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.0/patches/build.patch
rename to recipes-openharmony/sdk/openharmony-3.0/patches/build.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.0/patches/build_third_party.patch b/recipes-openharmony/sdk/openharmony-3.0/patches/build_third_party.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.0/patches/build_third_party.patch
rename to recipes-openharmony/sdk/openharmony-3.0/patches/build_third_party.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.0/patches/developtools_profiler.patch b/recipes-openharmony/sdk/openharmony-3.0/patches/developtools_profiler.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.0/patches/developtools_profiler.patch
rename to recipes-openharmony/sdk/openharmony-3.0/patches/developtools_profiler.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.0/patches/drivers_adapter_khdf_linux.patch b/recipes-openharmony/sdk/openharmony-3.0/patches/drivers_adapter_khdf_linux.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.0/patches/drivers_adapter_khdf_linux.patch
rename to recipes-openharmony/sdk/openharmony-3.0/patches/drivers_adapter_khdf_linux.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.0/patches/drivers_framework.patch b/recipes-openharmony/sdk/openharmony-3.0/patches/drivers_framework.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.0/patches/drivers_framework.patch
rename to recipes-openharmony/sdk/openharmony-3.0/patches/drivers_framework.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.0/patches/drivers_peripheral.patch b/recipes-openharmony/sdk/openharmony-3.0/patches/drivers_peripheral.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.0/patches/drivers_peripheral.patch
rename to recipes-openharmony/sdk/openharmony-3.0/patches/drivers_peripheral.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.0/patches/kernel_linux_build.patch b/recipes-openharmony/sdk/openharmony-3.0/patches/kernel_linux_build.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.0/patches/kernel_linux_build.patch
rename to recipes-openharmony/sdk/openharmony-3.0/patches/kernel_linux_build.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.0/patches/third_party_e2fsprogs.patch b/recipes-openharmony/sdk/openharmony-3.0/patches/third_party_e2fsprogs.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.0/patches/third_party_e2fsprogs.patch
rename to recipes-openharmony/sdk/openharmony-3.0/patches/third_party_e2fsprogs.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.0/patches/third_party_flutter.patch b/recipes-openharmony/sdk/openharmony-3.0/patches/third_party_flutter.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.0/patches/third_party_flutter.patch
rename to recipes-openharmony/sdk/openharmony-3.0/patches/third_party_flutter.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.0/patches/third_party_grpc.patch b/recipes-openharmony/sdk/openharmony-3.0/patches/third_party_grpc.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.0/patches/third_party_grpc.patch
rename to recipes-openharmony/sdk/openharmony-3.0/patches/third_party_grpc.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.0/patches/third_party_icu.patch b/recipes-openharmony/sdk/openharmony-3.0/patches/third_party_icu.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.0/patches/third_party_icu.patch
rename to recipes-openharmony/sdk/openharmony-3.0/patches/third_party_icu.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.0/third_party/openssl/BUILD.gn b/recipes-openharmony/sdk/openharmony-3.0/third_party/openssl/BUILD.gn
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.0/third_party/openssl/BUILD.gn
rename to recipes-openharmony/sdk/openharmony-3.0/third_party/openssl/BUILD.gn
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/BUILD.gn b/recipes-openharmony/sdk/openharmony-3.1/BUILD.gn
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/BUILD.gn
rename to recipes-openharmony/sdk/openharmony-3.1/BUILD.gn
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/BUILD_host.gn b/recipes-openharmony/sdk/openharmony-3.1/BUILD_host.gn
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/BUILD_host.gn
rename to recipes-openharmony/sdk/openharmony-3.1/BUILD_host.gn
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/BUILD_target.gn b/recipes-openharmony/sdk/openharmony-3.1/BUILD_target.gn
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/BUILD_target.gn
rename to recipes-openharmony/sdk/openharmony-3.1/BUILD_target.gn
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/ace_ace_engine.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/ace_ace_engine.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/ace_ace_engine.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/ace_ace_engine.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/ace_napi.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/ace_napi.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/ace_napi.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/ace_napi.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/ark_js_runtime.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/ark_js_runtime.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/ark_js_runtime.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/ark_js_runtime.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/ark_runtime_core.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/ark_runtime_core.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/ark_runtime_core.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/ark_runtime_core.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/ark_ts2abc.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/ark_ts2abc.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/ark_ts2abc.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/ark_ts2abc.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/base_notification_ans_standard.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/base_notification_ans_standard.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/base_notification_ans_standard.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/base_notification_ans_standard.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/base_update_updater.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/base_update_updater.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/base_update_updater.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/base_update_updater.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/base_usb_usb_manager.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/base_usb_usb_manager.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/base_usb_usb_manager.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/base_usb_usb_manager.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/base_user_iam_pin_auth.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/base_user_iam_pin_auth.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/base_user_iam_pin_auth.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/base_user_iam_pin_auth.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/build.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/build.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/build.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/build.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/build_lite.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/build_lite.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/build_lite.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/build_lite.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/build_third_party.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/build_third_party.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/build_third_party.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/build_third_party.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/developtools_hdc_standard.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/developtools_hdc_standard.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/developtools_hdc_standard.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/developtools_hdc_standard.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/developtools_hiperf.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/developtools_hiperf.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/developtools_hiperf.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/developtools_hiperf.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/developtools_profiler.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/developtools_profiler.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/developtools_profiler.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/developtools_profiler.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/drivers_adapter_khdf_linux.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/drivers_adapter_khdf_linux.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/drivers_adapter_khdf_linux.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/drivers_adapter_khdf_linux.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/drivers_framework.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/drivers_framework.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/drivers_framework.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/drivers_framework.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/drivers_peripheral.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/drivers_peripheral.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/drivers_peripheral.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/drivers_peripheral.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/foundation_aafwk_standard.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/foundation_aafwk_standard.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/foundation_aafwk_standard.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/foundation_aafwk_standard.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/foundation_appexecfwk_standard.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/foundation_appexecfwk_standard.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/foundation_appexecfwk_standard.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/foundation_appexecfwk_standard.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/foundation_graphic_standard.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/foundation_graphic_standard.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/foundation_graphic_standard.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/foundation_graphic_standard.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/kernel_linux_build.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/kernel_linux_build.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/kernel_linux_build.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/kernel_linux_build.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/productdefine_common.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/productdefine_common.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/productdefine_common.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/productdefine_common.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/third_party_e2fsprogs-backports-to-3.1.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/third_party_e2fsprogs-backports-to-3.1.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/third_party_e2fsprogs-backports-to-3.1.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/third_party_e2fsprogs-backports-to-3.1.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/third_party_e2fsprogs.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/third_party_e2fsprogs.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/third_party_e2fsprogs.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/third_party_e2fsprogs.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/third_party_flutter.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/third_party_flutter.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/third_party_flutter.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/third_party_flutter.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/third_party_grpc.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/third_party_grpc.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/third_party_grpc.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/third_party_grpc.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/third_party_icu.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/third_party_icu.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/third_party_icu.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/third_party_icu.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/third_party_libevdev.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/third_party_libevdev.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/third_party_libevdev.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/third_party_libevdev.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/third_party_libusb.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/third_party_libusb.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/third_party_libusb.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/third_party_libusb.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/patches/third_party_selinux.patch b/recipes-openharmony/sdk/openharmony-3.1/patches/third_party_selinux.patch
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/patches/third_party_selinux.patch
rename to recipes-openharmony/sdk/openharmony-3.1/patches/third_party_selinux.patch
diff --git a/recipes-openharmony/prebuilts/openharmony-3.1/third_party/openssl/BUILD.gn b/recipes-openharmony/sdk/openharmony-3.1/third_party/openssl/BUILD.gn
similarity index 100%
rename from recipes-openharmony/prebuilts/openharmony-3.1/third_party/openssl/BUILD.gn
rename to recipes-openharmony/sdk/openharmony-3.1/third_party/openssl/BUILD.gn
diff --git a/recipes-openharmony/prebuilts/sanity-check.inc b/recipes-openharmony/sdk/sanity-check.inc
similarity index 100%
rename from recipes-openharmony/prebuilts/sanity-check.inc
rename to recipes-openharmony/sdk/sanity-check.inc