diff --git a/recipes-devtools/hapsigner/hapsigner-native_1.0.0.bb b/recipes-devtools/hapsigner/hapsigner-native_1.0.0.bb
index 92283780682dea4fdc413d593d428dd10a5640bf..fb9b9fdf9b33a803e068179207241789a7e9a5c8 100644
--- a/recipes-devtools/hapsigner/hapsigner-native_1.0.0.bb
+++ b/recipes-devtools/hapsigner/hapsigner-native_1.0.0.bb
@@ -6,8 +6,6 @@ SUMMARY = "HAP signer tool"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
-inherit native
-
 S = "${WORKDIR}/src"
 
 SRC_URI = "git://gitee.com/openharmony/developtools_hapsigner.git;protocol=http;branch=OpenHarmony-3.1-Release;rev=ff2cf76f14f7d6c6fa55c9d0f02c4c1eb9c795a9;destsuffix=${S}"
@@ -33,3 +31,6 @@ do_install() {
 	install -m 0644 dist/OpenHarmony.p12 ${D}/${DSTDIR}/
 	install -m 0644 dist/OpenHarmonyApplication.pem ${D}/${DSTDIR}/
 }
+
+# native class must be inherited last
+inherit native
diff --git a/recipes-devtools/packing-tool/packing-tool-native_3.1.bb b/recipes-devtools/packing-tool/packing-tool-native_3.1.bb
index e50eb7592d9ee73da668f981a96b28693023a2d2..12da317ff64d558068826385f90c3df1177c823e 100644
--- a/recipes-devtools/packing-tool/packing-tool-native_3.1.bb
+++ b/recipes-devtools/packing-tool/packing-tool-native_3.1.bb
@@ -6,7 +6,7 @@ SUMMARY = "OpenHarmony Packing Tool"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=a832eda17114b48ae16cda6a500941c2"
 
-inherit cmake native
+inherit cmake
 
 require recipes-openharmony/openharmony/java-tools.inc
 
@@ -19,3 +19,6 @@ SRC_URI += "file://fastjson-pkg-name.patch"
 # Fetch fastjson-2.0.7.jar package from maven repository. Licensed under Apache 2.0
 SRC_URI += "https://search.maven.org/remote_content?g=com.alibaba&a=fastjson&v=2.0.7;unpack=0;subdir=${S}/lib;downloadfilename=fastjson.jar;name=fastjson"
 SRC_URI[fastjson.sha256sum] = "902de86ba19b188efca83f3138b1004578882de4306d6e70463dbc89595bf6b7"
+
+# native class must be inherited last
+inherit native