diff --git a/recipes-devtools/python/python3-prompt-toolkit1_1.0.18.bb b/recipes-devtools/python/python3-prompt-toolkit1_1.0.18.bb
new file mode 100644
index 0000000000000000000000000000000000000000..8fc3016c539603f569b0af3777a5762bd1e67a71
--- /dev/null
+++ b/recipes-devtools/python/python3-prompt-toolkit1_1.0.18.bb
@@ -0,0 +1,26 @@
+# SPDX-FileCopyrightText: Huawei Inc.
+#
+# SPDX-License-Identifier: Apache-2.0
+
+SUMMARY = "Library for building powerful interactive command lines in Python (version 1.0)"
+HOMEPAGE = "https://python-prompt-toolkit.readthedocs.io/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b2cde7da89f0c1f3e49bf968d00d554f"
+
+SRC_URI[sha256sum] = "dd4fca02c8069497ad931a2d09914c6b0d1b50151ce876bc15bde4c747090126"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "prompt_toolkit"
+
+RDEPENDS:${PN} += " \
+    ${PYTHON_PN}-core \
+    ${PYTHON_PN}-six \
+    ${PYTHON_PN}-terminal \
+    ${PYTHON_PN}-threading \
+    ${PYTHON_PN}-wcwidth \
+    ${PYTHON_PN}-datetime \
+    ${PYTHON_PN}-shell \
+"
+
+BBCLASSEXTEND = "native nativesdk"