diff --git a/recipes-core/musl/musl_%.bbappend b/recipes-core/musl/musl_%.bbappend
index 82812d403be5ef0d0adb31bf8d7db50148986caf..460b14ab8ca15677a550bf77af3e3714a8a992ce 100644
--- a/recipes-core/musl/musl_%.bbappend
+++ b/recipes-core/musl/musl_%.bbappend
@@ -2,14 +2,14 @@
 #
 # SPDX-License-Identifier: Apache-2.0
 
-BASEVER:oniro-openharmony-linux = "1.2.0"
-SRCREV:oniro-openharmony-linux = "040c1d16b468c50c04fc94edff521f1637708328"
-LIC_FILES_CHKSUM:oniro-openharmony-linux = "file://COPYRIGHT;md5=f95ee848a08ad253c04723da00cedb01"
-FILESEXTRAPATHS:prepend:oniro-openharmony-linux := "${THISDIR}/openharmony-${OPENHARMONY_VERSION}:"
-SRC_URI:append:oniro-openharmony-linux = " file://openharmony-common.patch"
-SRC_URI:append:oniro-openharmony-linux = " file://openharmony-linux-user.patch"
+BASEVER:openharmony = "1.2.0"
+SRCREV:openharmony = "040c1d16b468c50c04fc94edff521f1637708328"
+LIC_FILES_CHKSUM:openharmony = "file://COPYRIGHT;md5=f95ee848a08ad253c04723da00cedb01"
+FILESEXTRAPATHS:prepend:openharmony := "${THISDIR}/openharmony-${OPENHARMONY_VERSION}:"
+SRC_URI:append:openharmony = " file://openharmony-common.patch"
+SRC_URI:append:openharmony = " file://openharmony-linux-user.patch"
 # This conflicts with libcap, so we have to go with libcap instead
-#SRC_URI:append:oniro-openharmony-linux = " file://openharmony-linux-user-capability_h.patch"
+#SRC_URI:append:openharmony = " file://openharmony-linux-user-capability_h.patch"
 
 # As musl links with -nostdlib, we need to add linking with
 # libclang_rt.builtins.a manually as needed
@@ -22,9 +22,9 @@ LDFLAGS:append:toolchain-clang = " ${@bb.utils.contains('COMPILER_RT', '-rtlib=c
 # with `-nostdinc` argument.
 # Possible fix is to rewrite the hooks implementation to use the musl internal
 # atomic.h functions instead.
-#CFLAGS:append:oniro-openharmony-linux = "-DHOOK_ENABLE"
+#CFLAGS:append:openharmony = "-DHOOK_ENABLE"
 
-do_install:append:oniro-openharmony-linux () {
+do_install:append:openharmony () {
     for folder in ${MUSL_LDSO_PATHS}; do
         echo "${libdir}/${folder}" >> ${D}${sysconfdir}/ld-musl-${MUSL_LDSO_ARCH}.path
     done