diff --git a/recipes-openharmony/openharmony/openharmony-standard-3.0/graphic-standard-Add-missing-entry-for-libwms_client.patch b/recipes-openharmony/openharmony/openharmony-standard-3.0/graphic-standard-Add-missing-entry-for-libwms_client.patch
new file mode 100644
index 0000000000000000000000000000000000000000..e779359086eb1a05bbd958d9f637cf45b90e1dbf
--- /dev/null
+++ b/recipes-openharmony/openharmony/openharmony-standard-3.0/graphic-standard-Add-missing-entry-for-libwms_client.patch
@@ -0,0 +1,24 @@
+# SPDX-FileCopyrightText: Huawei Inc.
+#
+# SPDX-License-Identifier: Apache-2.0
+
+graphic-standard: Add missing entry for libwms_client
+
+libwms_client is required by the libcamera_napi library but is not being
+installed to the system image.
+
+Signed-off-by: Robert Drab <robert.drab@huawei.com>
+Upstream-Status: Inactive-Upstream [OpenHarmony 3.0 upstream repository https://gitee.com/openharmony/graphic_standard marked as closed]
+
+diff --git a/ohos.build b/ohos.build
+index f2b6d0da..827f223a 100755
+--- a/ohos.build
++++ b/ohos.build
+@@ -20,6 +20,7 @@
+ 
+         "//foundation/graphic/standard/frameworks/bootanimation:bootanimation",
+         "//foundation/graphic/standard/frameworks/bootanimation:bootanimation-480x960.raw",
++        "//foundation/graphic/standard:libwms_client",
+         "//foundation/graphic/standard:default.scss",
+         "//foundation/graphic/standard:graphic.rc"
+       ],
diff --git a/recipes-openharmony/openharmony/openharmony-standard_3.0.bb b/recipes-openharmony/openharmony/openharmony-standard_3.0.bb
index 1a8a349a5ff801b33729d74388654da5eb8d470d..637708a38e9e6c64b7417e13bca839e1ee594b1c 100644
--- a/recipes-openharmony/openharmony/openharmony-standard_3.0.bb
+++ b/recipes-openharmony/openharmony/openharmony-standard_3.0.bb
@@ -62,6 +62,7 @@ SRC_URI += "file://hihope-gralloc-Backport-to-3.0.patch;patchdir=${S}/device/hih
 SRC_URI += "file://ivi-input-controller.c-Fix-g_ctx-declaration-causing-segfault.patch;patchdir=${S}/third_party/wayland-ivi-extension"
 SRC_URI += "file://xf86drm.c-Add-drmWaitVBlank-hack.patch;patchdir=${S}/third_party/libdrm"
 
+SRC_URI += "file://graphic-standard-Add-missing-entry-for-libwms_client.patch;patchdir=${S}/foundation/graphic/standard"
 
 inherit python3native gn_base ptest
 
@@ -357,10 +358,5 @@ RDEPENDS:${PN}-ptest += "${PN}-hilog-ptest ${PN}-hilog"
 INSANE_SKIP:${PN} = "already-stripped"
 EXCLUDE_FROM_SHLIBS = "1"
 
-# We have the following problem:
-# ERROR: openharmony-standard-3.0-r0 do_package_qa: QA Issue: /usr/lib/module/multimedia/libcamera_napi.z.so contained in package openharmony-standard requires libwms_client.z.so, but no providers found in RDEPENDS:openharmony-standard? [file-rdeps]
-# and seems to be a bug in OpenHarmony 3.0
-INSANE_SKIP:${PN} = "file-rdeps"
-
 # To avoid excessive diskspace blowup, we are stripping our executables
 INSANE_SKIP:${PN} += "already-stripped"