diff --git a/recipes-openharmony/openharmony/openharmony-standard-3.0/ace_engine-disable-create-component.patch b/recipes-openharmony/openharmony/openharmony-standard-3.0/ace_engine-disable-create-component.patch
deleted file mode 100644
index 1197b21483a3540b5ab8d68102555af7f682b45f..0000000000000000000000000000000000000000
--- a/recipes-openharmony/openharmony/openharmony-standard-3.0/ace_engine-disable-create-component.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-# SPDX-FileCopyrightText: Huawei Inc.
-#
-# SPDX-License-Identifier: Apache-2.0
-
-foundation/ace/ace_engine: disable graphics
-
-The graphics rendering is slowing the system making some ACTS test suites to timeout.
-Since we are aiming for certification for headless system, graphics stack 
-should not be required.
-Disabling graphics by skipping JSView::CreateComponent() execution.
-In the future we will remove this patch when we the graphical part will be needed.
-
-Apply to foundation/ace/ace_engine
-
-Upstream-Status: Inappropriate
-
-Signed-off-by: Francesco Pham <francesco.pham@huawei.com>
-diff --git a/frameworks/bridge/declarative_frontend/jsview/js_view.cpp b/frameworks/bridge/declarative_frontend/jsview/js_view.cpp
-index e455cb00..d58d5c79 100644
---- a/frameworks/bridge/declarative_frontend/jsview/js_view.cpp
-+++ b/frameworks/bridge/declarative_frontend/jsview/js_view.cpp
-@@ -254,6 +254,7 @@ RefPtr<OHOS::Ace::Component> JSView::CreateComponent()
- 
-     std::string key = ViewStackProcessor::GetInstance()->ProcessViewId(viewId_);
-     auto composedComponent = AceType::MakeRefPtr<ComposedComponent>(key, "view");
-+    return composedComponent;
- 
-     // add callback for element creation to component, and get pointer reference
-     // to the element on creation. When state of this view changes, mark the
diff --git a/recipes-openharmony/openharmony/openharmony-standard_3.0.bb b/recipes-openharmony/openharmony/openharmony-standard_3.0.bb
index 42847eb937b0077a52746f77611944b65c82f8dc..dbf7c0f993ee1c844edf4915096b1df59db380c6 100644
--- a/recipes-openharmony/openharmony/openharmony-standard_3.0.bb
+++ b/recipes-openharmony/openharmony/openharmony-standard_3.0.bb
@@ -99,7 +99,6 @@ SRC_URI += "file://test-xts-acts-start-ability-timeout-increment.patch;patchdir=
 SRC_URI += "file://test-xts-acts-fix-Defpermission-typo.patch;patchdir=${S}/test/xts/acts"
 SRC_URI += "file://test-xts-acts-fix-faultloggertest.patch;patchdir=${S}/test/xts/acts"
 SRC_URI += "file://test-xts-acts-fix-hicolliecpptest.patch;patchdir=${S}/test/xts/acts"
-SRC_URI += "file://ace_engine-disable-create-component.patch;patchdir=${S}/foundation/ace/ace_engine"
 SRC_URI += "file://test-xts-acts-increase-testsuite-timeouts.patch;patchdir=${S}/test/xts/acts"
 SRC_URI += "file://actsgetwantalltest-wait-between-testcases.patch;patchdir=${S}/test/xts/acts"
 SRC_URI += "file://actsfeatureabilitytest-wait-between-testcases.patch;patchdir=${S}/test/xts/acts"