From 10f0c22cf99d8fe6e29c157fe7ca9cd6219df232 Mon Sep 17 00:00:00 2001
From: Esben Haabendal <esben.haabendal@huawei.com>
Date: Thu, 20 Jan 2022 15:30:35 +0100
Subject: [PATCH] openssl: Allow disabling of various ciphers and protocols

This is just a small subset of configuration options supported by OpenSSL code
base. Adding all of them to openssl recipe would be huge, and require continous
tracking for each new version, so is probably not diserable upstream.

These options is what we need for OpenHarmony configuration for now.

Signed-off-by: Esben Haabendal <esben.haabendal@huawei.com>
---
 recipes-connectivity/openssl/openssl_%.bbappend | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
 create mode 100644 recipes-connectivity/openssl/openssl_%.bbappend

diff --git a/recipes-connectivity/openssl/openssl_%.bbappend b/recipes-connectivity/openssl/openssl_%.bbappend
new file mode 100644
index 00000000..3fe7ce2a
--- /dev/null
+++ b/recipes-connectivity/openssl/openssl_%.bbappend
@@ -0,0 +1,16 @@
+# SPDX-FileCopyrightText: Huawei Inc.
+#
+# SPDX-License-Identifier: Apache-2.0
+
+PACKAGECONFIG[no-bf]		= "no-bf"
+PACKAGECONFIG[no-camellia]	= "no-camellia"
+PACKAGECONFIG[no-cast]		= "no-cast"
+PACKAGECONFIG[no-ct]		= "no-ct"
+PACKAGECONFIG[no-md2]		= "no-md2"
+PACKAGECONFIG[no-rc5]		= "no-rc5"
+PACKAGECONFIG[no-rc2]		= "no-rc2"
+PACKAGECONFIG[no-ripemd]	= "no-ripemd"
+PACKAGECONFIG[no-rmd160]	= "no-rmd160"
+PACKAGECONFIG[no-ssl2]		= "no-ssl2"
+PACKAGECONFIG[no-ssl3]		= "no-ssl3"
+PACKAGECONFIG[no-ssl3-method]	= "no-ssl3-method"
-- 
GitLab