diff --git a/meta-zephyr-core/recipes-kernel/zephyr-kernel/zephyr-openthread-rcp.bb b/meta-zephyr-core/recipes-kernel/zephyr-kernel/zephyr-openthread-rcp.bb
index 99d87326311d67bf91b47b40b07f4a4667a2f370..57fdba800d73e0f071c9ae8449fd184c51f869d5 100644
--- a/meta-zephyr-core/recipes-kernel/zephyr-kernel/zephyr-openthread-rcp.bb
+++ b/meta-zephyr-core/recipes-kernel/zephyr-kernel/zephyr-openthread-rcp.bb
@@ -7,7 +7,7 @@ EXTRA_OECMAKE += "-DCONF_FILE="prj.conf overlay-rcp.conf overlay-usb-nrf-br.conf
 # The overlay config and OpenThread itself imposes some specific requirements
 # towards the boards (e.g. flash layout and ieee802154 radio) so we need to
 # limit to known working machines here.
-COMPATIBLE_MACHINE = "(arduino-nano-33-ble|nrf52840dk-nrf52840)"
+COMPATIBLE_MACHINE = "(arduino-nano-33-ble|nrf52840dk-nrf52840|nrf52840-mdk-usb-dongle)"
 
 python __anonymous() {
     has_acm0 = d.getVar("ONIRO_ENABLE_ACM0")