diff --git a/meta-zephyr-core/recipes-kernel/zephyr-kernel/zephyr-openthread-rcp.bb b/meta-zephyr-core/recipes-kernel/zephyr-kernel/zephyr-openthread-rcp.bb
index 708e56a4686d3e7c65d54f4d4e2b695cd8d0e8a7..6d3f8608c2721af81c95e5a15a43ac60caebb57a 100644
--- a/meta-zephyr-core/recipes-kernel/zephyr-kernel/zephyr-openthread-rcp.bb
+++ b/meta-zephyr-core/recipes-kernel/zephyr-kernel/zephyr-openthread-rcp.bb
@@ -2,7 +2,7 @@ include zephyr-sample.inc
 
 ZEPHYR_SRC_DIR = "${S}/samples/net/openthread/coprocessor"
 
-EXTRA_OECMAKE += "-DCONF_FILE="prj.conf overlay-rcp.conf overlay-usb-nrf-br.conf" -DDTC_OVERLAY_FILE="usb.overlay""
+EXTRA_OECMAKE += "-DCONF_FILE="prj.conf overlay-rcp.conf overlay-usb-nrf-br.conf" -DDTC_OVERLAY_FILE="usb.overlay" -DCONFIG_OPENTHREAD_THREAD_VERSION_1_2=y"
 
 # The overlay config and OpenThread itself imposes some specific requirements
 # towards the boards (e.g. flash layout and ieee802154 radio) so we need to