diff --git a/meta-zephyr-core/recipes-kernel/zephyr-kernel/files/0001-console-enable-the-USB-ACM0-console-by-default.patch b/meta-zephyr-core/recipes-kernel/zephyr-kernel/files/0001-console-enable-the-USB-ACM0-console-by-default.patch
index 21a3d93ea02b51f8fd9fe06fde6481dae185af9b..96666a4a898431fe4ac05ea93b312f29ea015a98 100644
--- a/meta-zephyr-core/recipes-kernel/zephyr-kernel/files/0001-console-enable-the-USB-ACM0-console-by-default.patch
+++ b/meta-zephyr-core/recipes-kernel/zephyr-kernel/files/0001-console-enable-the-USB-ACM0-console-by-default.patch
@@ -1,4 +1,4 @@
-From e7a751f8003e85c93317bc0edfdc5e0cf589d17c Mon Sep 17 00:00:00 2001
+From fe9c7b4eaa93dd1b649d678d1a8b9cba51d0f7f5 Mon Sep 17 00:00:00 2001
 From: Bartosz Golaszewski <bartosz.golaszewski@huawei.com>
 Date: Thu, 27 Jan 2022 10:26:41 +0100
 Subject: [PATCH] console: enable the USB ACM0 console by default
@@ -7,10 +7,10 @@ Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@huawei.com>
 ---
  boards/arm/arduino_nano_33_ble/CMakeLists.txt |  3 +++
  .../arduino_nano_33_ble.dts                   |  9 +++++++
- .../arduino_nano_33_ble_defconfig             |  6 +++++
+ .../arduino_nano_33_ble_defconfig             |  7 ++++++
  .../src/init_usb_cdc_acm.c                    | 25 +++++++++++++++++++
  subsys/shell/shell_uart.c                     |  2 +-
- 5 files changed, 44 insertions(+), 1 deletion(-)
+ 5 files changed, 45 insertions(+), 1 deletion(-)
  create mode 100644 boards/arm/arduino_nano_33_ble/src/init_usb_cdc_acm.c
 
 diff --git a/boards/arm/arduino_nano_33_ble/CMakeLists.txt b/boards/arm/arduino_nano_33_ble/CMakeLists.txt
@@ -52,10 +52,10 @@ index 7e509086d2..aa769b87f0 100644
  // All PWM's should be enaled
  &pwm0 {
 diff --git a/boards/arm/arduino_nano_33_ble/arduino_nano_33_ble_defconfig b/boards/arm/arduino_nano_33_ble/arduino_nano_33_ble_defconfig
-index ba8eeee931..652d79e6cd 100644
+index 5fbe4ccdfb..dfe0507822 100644
 --- a/boards/arm/arduino_nano_33_ble/arduino_nano_33_ble_defconfig
 +++ b/boards/arm/arduino_nano_33_ble/arduino_nano_33_ble_defconfig
-@@ -19,3 +19,9 @@ CONFIG_BOOTLOADER_BOSSA_LEGACY=y
+@@ -18,3 +18,10 @@ CONFIG_BOOTLOADER_BOSSA_LEGACY=y
  
  # additional board options
  CONFIG_GPIO_AS_PINRESET=y
@@ -65,9 +65,10 @@ index ba8eeee931..652d79e6cd 100644
 +
 +CONFIG_UART_LINE_CTRL=y
 +CONFIG_USB_UART_CONSOLE=y
++CONFIG_BOARD_ARDUINO_NANO_33_BLE_EN_USB_CONSOLE=y
 diff --git a/boards/arm/arduino_nano_33_ble/src/init_usb_cdc_acm.c b/boards/arm/arduino_nano_33_ble/src/init_usb_cdc_acm.c
 new file mode 100644
-index 0000000000..820dcc2b7a
+index 0000000000..a429cc5c8c
 --- /dev/null
 +++ b/boards/arm/arduino_nano_33_ble/src/init_usb_cdc_acm.c
 @@ -0,0 +1,25 @@
@@ -95,7 +96,7 @@ index 0000000000..820dcc2b7a
 +		k_sleep(K_MSEC(100));
 +	}
 +}
-+SYS_INIT(board_internal_usb_cdc_acm_init, APPLICATION, 32);
++SYS_INIT(board_internal_usb_cdc_acm_init, APPLICATION, 99);
 diff --git a/subsys/shell/shell_uart.c b/subsys/shell/shell_uart.c
 index 64b53e29fc..24d647ac58 100644
 --- a/subsys/shell/shell_uart.c