GitLab will be shut down on June 25 to move to a new facility. https://www.eclipsestatus.io/incidents/5ffy27gwcbx7

Commit bf90c05d authored by amccaskey's avatar amccaskey
Browse files

Committing fix for bug 481958 javax.ws.rs version error.



The last commit added platform specific plugins to our target definition
and failed to resolve on Mac and Windows. I've reverted the target to
the previous configuration in this commit. I added a filter to the pom
platform resolution to just use the javax.ws.rs 1.1.1 plugin, not 2.0.1,
which revealed the 2.0.1 dependency came from the docker feature in the
target. I removed the docker tooling, and the 2.0.1 addition to the
target is gone. 

I'm leaving the filter for now to catch this bug in the future. We can
remove it though since no plugins are pulling in the 2.0.1 plugin. 
Signed-off-by: default avataramccaskey <mccaskeyaj@ornl.gov>
parent 28137a55
......@@ -175,7 +175,6 @@ Java and all Java-based trademarks are trademarks of Oracle Corporation in the U
<feature id="org.eclipse.cdt.bupc"/>
<feature id="org.eclipse.cdt.core.lrparser.feature"/>
<feature id="org.eclipse.cdt.core.parser.upc.feature"/>
<feature id="org.eclipse.cdt.docker.launcher"/>
<feature id="org.eclipse.cdt.gdb.source"/>
<feature id="org.eclipse.cdt.gnu.build.source"/>
<feature id="org.eclipse.cdt.gnu.debug.source"/>
......
This diff is collapsed.
......@@ -251,6 +251,16 @@
<classifier>mars</classifier>
</artifact>
</target>
<filters>
<!-- example 1: restrict version of a bundle -->
<filter>
<type>eclipse-plugin</type>
<id>javax.ws.rs</id>
<restrictTo>
<version>1.1.1.v20130318-1750</version> <!-- alternative: <version> for selecting exactly one versions -->
</restrictTo>
</filter>
</filters>
</configuration>
</plugin>
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment